6

Ever since I upgraded to the Windows 8.1 beta (and even now with the Windows 8.1 RTM), my computer will not idle to sleep. This wouldn't be that much of a problem since I almost always remember to put it to sleep before walking away. But sometimes the computer will wake on its own through a scheduled task, and then the computer will stay on until I return to it. (By the way, I'd rather not disable scheduled tasks from being able to wake the machine.)

The computer is set to sleep after 30 minutes of inactivity. I have set the Power Option "When sharing media" to "Allow the computer to sleep." I have deactivated all "wake_armed" devices so that

powercfg /devicequery wake_armed

returns

NONE

I have installed all the drivers Windows couldn't automatically detect (of which there was only my "Creative Game Port"). Finally, I have generated a report from

powercfg /energy duration 3600

Originally, it informed me of a few problems, such as the "When sharing media..." setting. As I said earlier, I have now set the "When sharing media" setting to "Allow the computer to sleep." Here is the report, which seems to suggest that I have no further serious problems:

https://skydrive.live.com/redir?resid=3D3292D8A7DEC2F4!17449&authkey=!AIllZ4c3A8_-XHU

SkyDrive will probably show the HTML upon clicking above. Try clicking Download and then opening the file. Thank you for your help.

1
  • I am also having this problem but the solution below did not work. Should I start a new question or somehow add that here?
    – josefec
    Dec 26, 2013 at 14:25

4 Answers 4

4

The answer was to leave the Homegroup (which I wasn't using anyway)! I started a thread in the Neowin.net Forums, and thanks to Kool Box for figuring it out:

http://www.neowin.net/forum/topic/1176793-windows-81-wont-sleep-when-idle/

1
  • That worked for me too. Wonder why that prevents sleeping? Oct 2, 2013 at 6:53
0

I had the same problem, but I did not have Homegroup activated at all.

The solution that worked for me was to turn off Play a slide show on the lock screen in the Lock Screen settings:

enter image description here

1
  • This setting was off by default for me. Nov 1, 2013 at 0:32
0

For me it was he "S4 sleep mode" in american megatrend Bios. After disabling the S4 mode, windows 8.1 could successfully sleep after remaining idle.

0

See here, I figured it out finally for my issues: Win 8.1 not going to sleep

I used an option (/WAKETIMERS) which I had not seen too often before on any helping forum, thus I'm posting it here:

powercfg /WAKETIMERS

-> To see the scheduled tasks. Helped me figure out to disable the Windows regular maintenance, which avoided sleeping completely (and not only waking it up in the night).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .