2

In a remote desktop session, both client and server are Windows 8 Pro (w/Media Center), UAC prompts appear as follows (username and Microsoft account e-mail intentionally obscured, it does appear correctly on the actual screen):

enter image description here

Now, neither client nor server has a smart card reader, so I use a password to approve elevation (and yes, I want to require password entry, not click-through). Notice that the smart card options appear above the password option and the preselected option is for a smart card, even though every time I've approved elevation I've done so with a password.

Can I either

  1. Get rid of the smart card options, or

  2. Make the dialog appear with the password option selected/focused and ready for password entry?


EDIT: "Smart cards" is not checked under "Local resources"

enter image description here

  • If you edit your RDP connectoid for that computer, and uncheck "Smart Cards" under Local Resources, does it still do it? – Ƭᴇcʜιᴇ007 Sep 9 '13 at 17:25
  • @techie007: See added screenshot, is that what you're referring to? It already was unchecked. – Ben Voigt Sep 9 '13 at 17:32
  • Yup, that's what I was talking about. :) Are you logged into the local computer with a domain account? – Ƭᴇcʜιᴇ007 Sep 9 '13 at 17:39
  • No, on the client I'm logged in with a local account (upgraded from Win7), and the server I'm logged in with a Microsoft account. – Ben Voigt Sep 9 '13 at 18:44
2

You need to disable Smartcard Credential Provider.

The easiest way is to use Autoruns tool from Sysinternals. In Winlogon tab disable mentioned provider (you may need to uncheck Hide Windows Entries in Options menu).

enter image description here

Alternatively you may just remove following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\Credential Providers\{8FD7E19C-3BF7-489B-A72C-846AB3678C96}

This worked for me on Windows 10, but it should work on Windows 8 too.

  • Thanks very much, this works perfectly and it also solves the major annoyance with the default button after typing a password being "No". Why would I go to the trouble of typing my password if I didn't intend to approve the action? Well, now that password entry is the default focus, the default button is also corrected. Thank you thank you thank you! – Ben Voigt Jul 17 '15 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.