12

Okay to make things clear; I'm going to give a step by step of what happened.

I've got a brand new laptop, and while installing stuff everything was fine. When I'd plug in headphones in the 3.5mm jack, all the sound would just go there instead of at my speakers, which is exactly as I want it. Then I called someone on skype, and my laptop decided that it'd play all the sound over it's own speakers, even if headphones were pluuged in. Though I can fix skype by changing skype's audio options(to play over 3.5mm jack), when I call someone, the rest of my sound still goed over the internal speakers.

I want all the sound to go through my headphones whenever they're plugged in, no matter what I do. What should I do?

2
  • Try using the "Find and fix audio playback problems" troubleshooter. Search for audio in the control panel and it should be listed under Troubleshooting. – Brian Dec 22 '13 at 1:15
  • @Brian total loss of time, these troubleshooters won't do any good. – user256743 Dec 11 '14 at 17:21

13 Answers 13

12

I'm assuming you haven't done this:

Go into your Sound settings from the Control Panel and set your head phones as the default device.

Are you on the screen below? A green tick should appear on the default device.

Sound Settings

15
  • 3
    I can change my headphones to 'default communication device' but not to 'default device'. The speakers are the 'default device' and it looks like I can't change that. I can only make the speakers the normal and communication default, but not neither. I can click on the 'set default' at my headphones, but it wont change. – Dawn Valentine Sep 9 '13 at 17:53
  • Hmmm, that's strange. Are you using earphones or a proper set of headphones? – Yass Sep 9 '13 at 18:00
  • I'm sure I'm in the right window. Internal speakers are default device. headphones are default communication device. I can click on make this the default device at the earphones, but it doesn't change anything. I'm using mobile phone earphones. one 3.5mm jack, extra contact for microphone which can't be used in laptop. – Dawn Valentine Sep 9 '13 at 18:03
  • It's not that I haven't done that.. It's that I can't. – Dawn Valentine Sep 9 '13 at 18:04
  • What about if you right-click on the headphones and choose Set as Default Device? I'm guessing that won't make a difference either. – Yass Sep 9 '13 at 18:05
10

The problem: There are two different 'default' devices. One for communications (Skype, Teamspeak, etc.) and one for everything else (e.g. games).

problem

The solution: Unplug the headphones, and set the speakers as both the 'default device' and the 'default communications device'.

solution

Now it should look like this:

result

Everything will play through the speakers. Plug the headphones back in. Everything will play through the headphones (even though speakers are still selected as default). This is another example of silly windoge logic. Some programs will change the 'default communications device' back to the headset on startup (Teamspeak did this to me).

4
  • 2
    Can't believe this worked - cheers – Robbie Averill Jul 20 '15 at 20:57
  • 1
    To make it work when Realtek Audio Manager installed I had to open Realtek, open Device advanced settings and then choose Mute the rear output device, when a front headphone plugged in. – BornToCode May 13 '16 at 2:43
  • BornToCode, thank you for that comment. I don't have a realtek device but I discovered that the auto-switching functionality can be turned off in my own soundcard settings, separate from windows. – Amalgovinus Mar 3 '17 at 6:03
  • That worked for me!! I can't believe it. Thanks @rudolfbyker. Windows plays with our mind. Send a hello form me to Bill Gates. – Daniel Silva Jul 5 '17 at 12:31
1

What I ended up doing that seemed to work was:

Control Panel >Manage Audio Devices

There should be 4 options; Playback, Recording, Sounds, and Communications. If you click on Recording look to see if there's an Internal Mic option in the list. If so, click on it then click properties. Another window will open up and from there click the Listen tab. If Listen to this Device is checked, uncheck it and click Apply.

1

I had the problem where my computer would show "speakers and headphones" as default device, and then a separate "communications headphones" category too. I am using iPod headphones with the microphone, so when I plugged in the headphones, they would go to the communications category.

What fixed it was when I disabled "communications headphones," then it would register my headphones as normal and work.

2
  • This is the correct answer; some PCs expose two independent sound devices, a speakers/headphones one and an "independent headphones" (or similar); disable the independent one and everything should work just fine (reconfigure your apps to use the "speakers/headphones" device). – user256743 Dec 11 '14 at 17:22
  • I've been struggling with a similar issue for months, and this is the only thing that helped me. My problem was anytime I had an alert pop up or I switched folders in the file explorer, it would momentarily re-route sound through the main speakers. This solution seems counter-intuitive, but it worked. – Sam Krygsheld Jun 13 '18 at 15:28
1

I was able to resolve this problem by uninstalling the audio drivers my computer came with and using generic audio drivers instead.

In my case:

  • Audio driver (problematic): IDT Audio
  • Playback device title: Communication Headphones
  • Audio driver (working): High Definition Audio Device

Uninstalling IDT Audio via the device manager resulted in IDT Audio automatically re-installing itself. After some experimentation I discovered a way to finally remove it:

  1. Go to Control Panel > Sound > Playback
  2. Right-click the playback device you want and select Properties
  3. Locate the Controller information section under the General tab and click the Properties button
  4. Navigate to Driver tab and click the Update Driver button
  5. Choose Browse my computer for driver software
  6. Click Let me pick from a list of device drivers on my computer
  7. Make sure Show compatible hardware is checked
  8. If options are available - continue to install them one-by-one until you've tried everything.

Following those steps fixed my sound problems immediately.

1

For me: unplugging my headphones, setting the speakers as the default and default communications device and then disabling the communication headphones bullish seemed to make all the sound play in the headphones when i use them.

0
0

I had the same problem. The way I fixed it was to open the sound tab by right clicking the speaker icon, click the headphones, and go to properties. Select advanced and uncheck the allow applications to take exclusive control of this device. Click OK. That should fix your problem.

0

This is pretty specific, but may help someone trying to figure this out. I was having the same issue, probably after installing skype, and on my laptop (HP Elitebook) I couldn't set the default device to "communication Headphones" through the windows interface, but was able to do it through the "Catalyst Control Center" (by right clicking and selecting it as default device). Now everything works as it did out of the box, playing through the speakers normally, and through headphones when they're connected.

0

I had same issue and I fixed it by disabling and re-enabling the headphone under Sounds -> Playback.,

0

I believe I've figured out the answer. I had the same issue and it was an interesting fix. See if this works for you.

  1. I right-clicked on the speaker icon in the Windows Start Bar and pressed Playback Devices.
  2. Right-click on the device that represents your 3.5mm headphone jack and select Properties.
  3. Go to the Enhancements tab.
  4. I found that no enhancements were enabled. I checked all the enhancement boxes (i.e. Bass Boost, Loudness Equalization).
  5. I had Pandora Internet Radio playing while I did this and it was playing from the laptop speakers only, even though the 3.5mm plug was plugged in (I was using it for speakers, not headphones). I hit the Apply button and the music immediately went to the external speakers).
0

Look! if you have the problem with headphones, this answer will help you. After Searching and many attempting, it worked.

I would suggest you to check with volume settings and check if it helps.

  1. Right click on the speaker icon in taskbar and select volume control options.

  2. put a check mark on "All devices currently playing sound".

  3. Make sure you have "The default communication device unchecked".

  4. Place a check mark on both speakers and headphones.

Yet, if it has been not changed, this is key. You have to plug a hand free(headphones) on its place and try these steps again. Eventually, It will work. Those steps based on my actual experiment.

1
  • 2
    When you say ‘‘Look!’’, you sound like you’re angry, or you’re making some big announcement.  When you say ‘‘this will help you’’, you sound like a salesman. Try to sound more like a teacher. – Scott Apr 2 '18 at 19:45
0

Try right clicking the sound icon on the notification area of the task bar then click Playback devices then right click speakers and disable it then do the same for the headphones then what you do is to re-enable the headphones first then the speakers then click ok.

P.S. it worked for me and even worked when i tried sound on discord afterwards

-1

Right-click the speaker icon in the notification area (it should have a red X on it) Choose "Playback devices" The Sound control panel should appear, on the "Playback Devices" tab - there won't be any playback devices visible. Right-click in the main area of the window where the devices would normally appear. Check the "Show Disabled Devices" option.

At this point your speakers should re-appear, but will still be disabled. Right-click the speakers and choose Enable

1
  • 2
    The question says nothing about the speakers disappearing. Where did you get that idea from? – lzam Oct 3 '14 at 2:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.