I have got DNS Bind9 server installed on my VirtualBox Debian host. Another host from the same network has the nameserver address set as IP_OF_MACHINE_WITH_BIND. This was working ok for some time. Then I tried to create my own local zone to assign domain names to my virtual hosts. But I have set something wrong: now my DNS server is not resolving any hosts. I tried to turn local zone settings off in named.conf.local, but it didn't helped.

The requests that hosts send to DNS server really reach it. I can see the messages of this kind in the logs:

client IP_OF_PINGER#some_counter query: www.google.com IN A + (IP_OF_DNS_SERVER)

Yes, I have set up the forwarders variable in named.conf.options, of course.

A question is: can you suggest me a methodology to debug my server's configuration and find out whats wrong with the settings? Which logs I should enable and how? How can I understand why server is not directing my request to provider's DNS servers, mentioned in named.conf.options as 'forwarders'?


This sounds like a syntax error. In no particular order:

1) Run named-checkconf against your named.conf syntax. Depending on your version, you may need to feed it the full path to named.conf

named-checkconf /etc/bind/named.conf

Hint: "named-checkconf -h" and "man named-checkconf" will provide extra details.

This tool only checks for syntax errors, not logic errors.

2) Sniff your traffic and determine if queries are actually being passed to the upstream DNS server.

tcpdump -n -i eth0 host IP_of_Upstream_DNS

3) Review all of your config files. "/etc/bind/named.conf" normally has at least three "include" statements, pointing to "named.conf.options", "named.conf.local", and "named.conf.default-zones". Since your forwarders statement is located "named.conf.options", make sure that's not commented out.

4) If all else fails, consider un-installing/re-installing BIND and starting from scratch. Before you edit any of the config files, make backups of them. THen make your changes gradually, check operation after every few changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.