Hello community,

This is my problem:

I'm trying to connect a DOS-machine to a Windows 7 computer, using a LAN-crossover-cable - and it won't work.

I want to access a shared directory on the Windows-PC from the DOS-machine. Best solution would be to assign a drive-letter to the shared directory and make that persistent.

I've done this before we got new hardware, establishing that connection from the DOS-machine to a Windows XP computer worked just fine.

Using Windows 7 now, it won't.


The Windows-PC

Running Windows 7 (Ultimate - or Professional, not sure right now) 64bit. There are two network cards in it, one for the logon via authentication server, internet and so on - and the second one only to build a connection to the DOS-Machine.

There is a separate local user specified, with name and password.

There is also a shared directory in C:\ with full acces rights to exactly that user.

(That's exactly what i did when using XP)

The DOS-machine

It's exactly that - a machine. Not a PC. It's a CNC machine with a special control software and so on. This control software is running on DOS and the network connections are built up via DOS, too.

I can't tell you which version of DOS - but scanning through the directorys i tend to say that this isn't some kind of "normal" DOS-version. Seems to be something "special" or "minimal", just to get the machine software running and providing basic things.

Using the mentioned XP-computer a while ago, i could use the NET commands to establish a connection using a drive letter, the shared network path - and the specified userdate, name and password.

That just worked. That so configured shared directory was visible and usable when running the machines control software - that's the goal of all this.

Current situation

Trying to build up the connection as i did before only results in the following error:

Error 53:

The computer specified in the network path cannot be located.

Explanation: The server that you specified does not exist or has not been startet.

...at least that's the error message when using the "GUI" the NET-command provides. When directly using NET USE ... the error code is the same, just the text message slightly different (...but basically saying the same).

As i'm not into networking that much, i have no idea what to do. There must have been some changes in the network protocols from XP to 7 - that's all i can say.

I've read something about a tweak using gpedit.msc and setting the "LAN Manager authentication level" to "Send LM & NTLM - use NTLMv2 session security if negotiated". Didn't do anything.

I've also read something about allowing "NetBIOS" on the network adapter on the Windows 7-PC, so i changed the advanced TCP/IP v4 settings - didn't do anything.

I've also stumbled upon an error on the DOS-machine - i can't use ping there. The command itself is somehow broken, instead of some appropriate message i only see undefinable characters on the screen. I don't know if that could have any influences on the network settings.

I didn't call the machine support by now - and i don't think i will. They are not very helpful with this network-issues, they weren't able to build up a working connection when we had XP (that's why i dit that by myself).

Plus, there is no useful documentation of the machine when it comes to that topics. Detailed informations simply doesn't exist - i've asked any possible adress for that, even the japanese manufacturer of the machine.


16. Sept. 2013

I've tried to connect to the Windows 7-PC using net use x: \\hostname\\shared_dir - that's leading to the mentioned Error 53. I also tried that command with the option /PERSISTENT:YES, same error.

I've tried net view \\hostname, that raised Error 53, too.

I get the same error when trying the computers IP instead of \\hostname - both on net use ... and net view ...

The command ver displays:

PC DOS Version 6.3

Revision 0

...so there's no MS-DOS running on the machine. I don't know how important that is, when it comes to this network connection.

Rik managed to connect his old 486-machine (runnning MS-DOS 6.22) to a Windows 7-Computer, see his answer below. I followed his steps and configured both systems like he did (changes in gpedit.msc, adding the computer to LMHOSTS, configured a new user, ...), without success - i'm not even getting various error-codes, i'm stuck with Error 53.

I don't know if it's mandatory, but i changed the workgroup and the domain for the DOS-machine to match the Windows 7-PC. That wasn't the case before. It didn't help to get this working, but raise a new kind of error, when trying net view \\hostname:

Error 6118: The list of servers for this workgroup is currently not available.

Whatever that means.

I also tried to connect another computer to this Windows 7-PC, so i brought my Notebook (running Windows 7) and unplugged the DOS-machine.

I could get a working connection between those Windows-computers at the first try, just as this should work. Both computers can ping, view and connect to the other one, all fine.

By doing this, i recognized that the two windows-machines were only talking to each other using IPv6. I'm pretty sure that the DOS-machine can't handle this new protocol and even using the two Windows-PCs, this connection shouldn't require IPv6. So i disabled this protocol from the network adapter settings.

Result: ...i lost the connection. No PC was able to ping, view or connect to the other one, they just couldn't find each other anymore.

After enabling IPv6 again, everything worked just fine.

...i don't know why this Windows 7-computers need IPv6 to communicate. I don't think it's "good" that way, as this could cause a problem when trying to connect the DOS-machine.

I don't know what's happening there - and where to make changes to get IPv4 working.

The machine is in use most of the time (...Data is transferred using Floppy-Disks), but as soon as there's time for it, i'll try any helpful suggestion.

Last Update:

There is no more need to think about this problem. Thanks for anyone who helped me trying several things!

Just look at the date - it's been 2013 when i tried to solve this problem. Not long after fiddling around with various settings, i've been told that it's not my job to look after this issue.

I just wanted to help, but have been told to mind my own business - and so i did.

Of course, it's still not working.

Two month ago, i overheared a conversation about this topic. Someone seems to have recognized that this broken connection is really annoying and should be fixed. Until now, nothing has happened.

Floppy discs FTW.

  • 1
    Without the exact command we would only be guessing. Did you specify the correct computername. i.e. NET USE X: \\CORRECT_COMPUTERNAME\CORRECT_SHARENAME? What do you get if you do a NET VIEW \\CORRECT_COMPUTERNAME?
    – Rik
    Sep 10, 2013 at 8:12
  • And instead of CORRECT_COMPUTERNAME you could also use its IP-address. i.e. NET VIEW \\IP_ADDRESS and NET USE X: \\IP_ADDRESS\CORRECT_SHARENAME.
    – Rik
    Sep 10, 2013 at 8:29
  • Hello Rik. First i tried to establish the connection using some kind of DOS-GUI the NET-command launches when only entered: C:\NET\net - that leads to the mentioned error. Then i tried to connect via commandline (...which is basically the same) using: C:\NET\NET USE G: \\CORRECT_COMPUTERNAME\CORRECT_SHARENAME /PERSISTENT:YES - same result, error-text slightly different. I did try to use the computers IP instead of the hostname - didn't change anything.
    – xph
    Sep 10, 2013 at 8:42
  • >error-text slightly different. ??? How different ;-? Did you try the NET VIEW command? Do you have access to another Windows-machine so you can check if the settings of Windows 7 are correct. (Firewall off, Network discovery on, File and printer sharing on, Public folder sharing on, Media streaming off, Password protected sharing off, Lowering the encryption to 40-56 bits, Are they in the same Workgroup)
    – Rik
    Sep 10, 2013 at 8:53
  • @Rik: The error message still displays "Error 53", just not the full-length as quoted in my question. It says "Error 53: The server that you specified does not exist or has not been startet." (...that's just some difference how this error is displayed, using commandline or this NET-GUI. Not a matter of the content itself.). I forgot to mention that NET VIEW \\CORRECT_COMPUTERNAME is leading to the same error message. As soon as i could, i'll try to connect to the Windows 7-PC from another computer. That's a good idea, i'll check that!
    – xph
    Sep 10, 2013 at 12:23

2 Answers 2


I can confirm that the "Microsoft Network Client v.3.0 for MS-DOS" on MS-DOS 6.22 can connect to a Windows 7 machine. I dusted off an old 486-machine with this client still on the harddrive.

I also got a error 53 trying to connect to a Windows 7 machine. (Even NET VIEW \\MACHINE_NAME gave the error 53.

I needed to adjust the LMHOSTS to include the machine-ip address.
(adding MACHINE_NAME to it).

After that i got an error 5: Access denied. I changed the following with gpedit.msc in Windows 7:

Network security:
LAN Manager authentication level: Send LM & NTLM - use NTLMv2 session security if negotiated
Do not store LAN Manager hash value on next password change: Disabled

You already did the first line but you need the second too (setting it to "Disabled").

After that i created a new user with a password (you can probably change your user but you need to change it or else it does not work).

After that i got an error 1: An internal error occurred on the NET VIEW \\MACHINE_NAME but i could create a driveletter with NET USE P: \\MACHINE_NAME\SHARE and access all its files.

So if you are using the same configuration (Network client and DOS-version) you should be able to get it working. Hope this helps.

  • Rik, you're pure awesome. +1 for the fact that you actually tried that! Great job, also in providing all the informations. But... that doesn't work for me. Might be because i'm not using "MS-DOS", but "PC DOS". I updated my question and added further details.
    – xph
    Sep 16, 2013 at 7:42
  • @xph 4 more questions. 1) What IP (v4 or v6) for the Win7-machine did you use adding in LMHOSTS on the DOS-machine? It should be the IPv4 for the Win7-machine. 2) What did you do to disable IPv6? Did you only uncheck it in the adapter or did you use the registry-keys? 3) What version of the "Network Client"? Do a NET VERSION. 4) Are you using a domain or workgroup? Here Microsoft stated for your error "Your workgroup name is different than your domain name.". I only use workgroup but both are the same in my SYSTEM.INI on the DOS-machine.
    – Rik
    Sep 16, 2013 at 8:25
  • 1) I used the IPv4 adress of the Windows 7 computer in the LMHOSTS of the DOS-machine. 2) I just did uncheck the setting in the adapter confuguration of the Windows 7 PC. As i'm not sure about when changes are available directly or after a reboot, i restartet the Windows PC after unchecking IPv6. 3) ...to be done the next time i can put my hands on the machine. I'll provide this information then. 4) On the Windows 7 PC, both workgroup and domain are identical. That's the name i set in the SYSTEM.INI, but i'm not sure if i added both, or just workgroup. Will check that, soon.
    – xph
    Sep 16, 2013 at 9:14
  • If i reboot and after the NET LOGON i do a NET VIEW i get a error 6118 too. Leaving the machine for 15 seconds and doing the NET VIEW again it worked. So don't do all the commands in one batch but type them in a prompt with a few seconds apart.
    – Rik
    Sep 16, 2013 at 9:49
  • I'm not working with a batchfile, i'm typing commands by myself. And i can tell you that i already did wait longer than 15 seconds - it takes me at least 20 seconds to walk from the computer to the machine. Plus, i'd checked various commands more than once, with a little waiting time between (trying a command, notice it doesn't work, check options on both sides, googling, checking options again, not changing anything, trying command again, still not working, and so on...). But thanks!
    – xph
    Sep 16, 2013 at 11:59

Your problem might be because of security reasons in Windows 7. The network is unidentified and Windows could block access. You should try making it "work" or "home" and/or disable your firewall. Also make sure that the shared folder has full access for all users and (see security tab in properties). Oh yes, you should also go to the advanced sharing settings and disable password protected sharing, so everyone can connect without specific credentials.

  • I can imagine that this are mandatory settings to establish a connection - but the things you mention have been done, without luck. I guess the two main reasons that it isn't working are - as you say - win 7 security settings (...there still might be other ones, restricting such connection attempts), and i also blame some malconfigured network settings, regarding the two network cards of the win 7 computer. But honestly, i don't care anymore. I've been told that it's not my job to look after such issues long ago - it's not my problem now. But thanks anyways!
    – xph
    Mar 27, 2015 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.