5

I am currently using the /Z flag in a Windows Robocopy command with the intention of creating a "restartable" copy job. However, when the copy command is re-executed after an interruption, the copy job restarts at the beginning. This is evidenced when the top destination file (which was already completely written before the job interruption) changes timestamp to 1/1/1980 at the job start. Since this is Robocopy's built-in mechanism to track its progress, the file is treated as an incomplete copy and then rewritten. This continues for all other files that have already been successfully written to destination.

So my question is how do I use the Robocopy command in a truly restartable mode?

Thank you in advance for your help on this matter.

  • 1
    Are you using the /B flag as well? Robocopy turns off restartable mode whenever backup mode is required to override ACLs on a file. – jpaugh Dec 8 '16 at 21:19
0

I know this is a really old thread, but if anyone is looking for an answer, I just posted one here: Is It OK To Stop Robocopy?

For the relevant part:

About the /Z option, this option ONLY works for "network transfers". I put that in quotes because local copies will NOT use the restartable mode; however if robocopy sees a network path, it will use restartable mode, even if the source and destination are local, (this could just be my version of robocopy since I'm not moving past Windows 7). If you share out your drive or a folder on the drive, (preferably to an account that only you have access to), and enable the Change permission(s), then use that path as the destination, it should work in restartable mode. Granted, there may be a hit in performance when using restartable mode.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.