1

I had Hamachi working normally for some time, then out of the blue it started giving me VPN error (showing that yellow triangle with an exclamation mark) for every single person on my networks and I wasn't able to do anything with them anymore.

I've tried re-installing Hamachi and it didn't work. Someone told me to download an older version, install it and then update, but the older versions (1.x) won't install at all, saying there was a problem installing the network driver.

So I manually deleted the Hamachi network adapter. Now whenever I re-install Hamachi 2 again, it gives me no errors, but the network adapter simply won't show up, and the VPN error continues on. I can join networks and see whether people are online or not, but I can't connect to any server on their machines anymore.

  • Right click a client with an error, then click Details. Next to the error in the Properties page that appears, click Details. What error description do you see there? – Moses Sep 10 '13 at 15:49
  • "Failed to connect to the network adapter. The peer isn't reachable through VPN" (I had to translate it from my language, so it might be a little different than what it shows in english) – Delta Sep 10 '13 at 15:55
  • Error messages like that are searchable in the support documentation for Hamachi: Why do I get the Failed to connect to Hamachi network adapter error?, Why do I receive Failed to Connect to Engine? – Moses Sep 10 '13 at 16:00
  • I'm sorry, but that page didn't solve my problem. The notwork adapter doesn't show up in the device manager in order for me to enable it nor does it show in the network connections folder. My firewall is the windows firewall and I reinstalled it once again with those 2 services (DHCP Client & Network Connections) surely running. – Delta Sep 10 '13 at 16:12
  • Try scanning your system for malwares. Scan your system with softwares like malwarebytes or spybot(both are free and very good). I had a similar problem in which i wasn't able to browse the net and hamachi always showed the error in your system. – user241704 Sep 10 '13 at 16:14
0

Check if your problem is that the OS did not allow to install the Virtual Network Adapter's driver. To check this go to the Control Panel -> System -> System Management (I hope I write this down the right way, I can't clearly remember the correct english names), if you find a "!" next to the Hamachi's Virtual Network Adapter, then this is the case:

Your OS found something wrong with the drivers signiture.

The solution is to restart your OS, press F8 rapidly before it starts booting and you will see a screen where you can start in Safe Mode, BUT don't do it, lower there is an option that's something like "allow unsigned drivers" choose this.

Now your OS starts and try installing Hamachi now, the Virtual Network Adapter's driver will install and it will work.

Credit goes to: lalas147 http://www.tomsguide.com/answers/id-2118330/logmein-hamachi-network-adapter-driver-installing.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.