I work behind a very strict firewall but I am able to browse (most) of the internet just fine with FireFox and I.E., however there are specific proxy settings to have. Namely, an autoconfig *.pac link that gives the settings.

Anyway, I am trying to run some Maven through commandline/powershell and it requires downloading something. Now, the file it wants to download works fine in IE/Firefox (this) however in cmnd/pshell it times out. In fact, I can't even ping external sites using cmd/pshell.

So, I think I realized I need to make sure that when cmd/pshell sends a request over the internet, it at least utalizes the I.E. proxy settings. How can I ensure it is doing that?

  • For PowerShell your script needs to be programmed to use the proxy - AFAIK you can't just set it system-wide for all PowerShell downloads. See this StackOverflow question: PowerShell, Web Requests, and Proxies – Ƭᴇcʜιᴇ007 Sep 10 '13 at 17:32
  • I understand system wide can't work, but I was hoping to set some environmental variable that will enable it to work. That link you provided didn't work. It was geared toward PowerShell -- I'd kind of prefer CommandLine though since all the guides specify command line to run Maven. – E.S. Sep 10 '13 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.