0

I have a Zotac ITX Z68 WiFi Supreme. The OS is linux. The default BIOS had a problem with the fan, so I decided to upgrade to 2K111012. Installed a freedos usb key, ran it without EMM386 and HIMEM (with I got illegal instruction problems), flashed the BIOS. All successful. I reboot, but now I get a message saying

"Reboot and select proper Boot Device or Insert Boot Media in selected boot device and press a key".

The USB key with freedos is unplugged of course. I checked and rechecked to make sure it boots from the hard drive, but it doesn't do it. Even selecting the HD by hand does not work. It boots, however, from the USB key.

How do I fix it?

I have a backup of the BIOS, so I can try to go back to the old image and hopefully it will work, but still...

Edit:

I can boot from USB without any problem, also a Linux install. I can also mount the hard drives. However, it seems I can't boot from them. I tried to reinstall grub, but no luck.

  • 1
    Did you write down all the settings before you flashed it, and ensure you put them back as they were (after you flashed it)? have you done a "Restore Defaults" of the BIOS settings and then (re)configure them to match what your system requires (RAID, AHCI, etc.)? Really, we don't know your setup, or what your BIOS was set to before the flash - only you do. :( – Ƭᴇcʜιᴇ007 Sep 10 '13 at 18:27
  • Sounds like the boot configuration of the hdd has changed. Have you verified the settings are the same from before you updated the BIOS? – Ramhound Sep 10 '13 at 18:28
  • everything is the same, and I reset the bios – Stefano Borini Sep 10 '13 at 18:33
  • by the way, I restarted from the USB key and tried to reflash, but now the flash utility gets stuck. Also, I don't have the backup image anymore (when I did the backup, I didn't know C: was on a ramdisk, and not on the usb key) – Stefano Borini Sep 10 '13 at 18:34
  • @techie007: the hard drive is a normal sata-II. Nothing fancy. – Stefano Borini Sep 10 '13 at 18:40
0

I solved the problem. The issue was the bootloader and I successfully recovered the system by following this

How to reinstall GRUB2 EFI?

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.