I want to prevent Windows from showing any wireless password. Is there a security database choice either on each individual computer or on the domain that will establish this policy?

  • 3
    Where is it showing the password now? – Colyn1337 Sep 11 '13 at 14:38
  • The default behavior in Windows is not to display the password as you type the WiFi password. What version of Windows are you using? – Ramhound Sep 11 '13 at 14:44
  • @Ramhound yes, but there is a little box you can check to expose the key... bad for multi user machines where you need it always obscured from most users – Austin T French Sep 11 '13 at 14:48
  • 2
    For those asking where is it being shown, see this SU question and answer. That check-box requires administrative privileges (notice the UAC shield in the 2nd answer in the question I linked to). Are the users that you not wanting to see the password running as an administrator on the computer? If so, any setting you set can be unset by them as they have the same rights as you. – Scott Chamberlain Sep 11 '13 at 14:52

The only way to do this is to disallow access for regular users to the Network and Sharing Center through GPO. There is no way to disable only the Show wireless key function, either locally or through GPO.

To disable Network & Sharing Center through GPO:

I have clients that have laptop users and the laptop users need local administrator rights on their computers. I found out that restricting access to the Network and Sharing Center did not prevent the ability to view and see the properties (including the wireless keys) for local administrators. I was still able to view these properties through a shortcut to Manage Wireless Networks and/or by right clicking on a WLAN adapter, then Status, then Wireless Properties. Therefore, I set out to find a different method to prevent access to this information using a Software Restriction Policies GPO. The method that I have used below is drastic as it prevents access to be able to edit WLAN profiles. Users can still connect to a wireless network they simply cannot edit any of the properties. Here’s how…

  1. Create a new GPO and link it to the OU where you want the policy applied.
  2. Edit the new GPO and navigate to User Configuration\Policies\Windows Settings\Security Settings\Software Restriction Policies.
  3. In the Object Type pane, double click on “Enforcement” and change the “Apply Software Restriction Policies to the following:” and check “All Software Files” which will include DLL files.
  4. Next go to the “Additional Rules” node, right click on the blank area and add a new path rule.
  5. In the Path field type C:\Windows\System32\wlanui.dll and select the security level as Disallowed. wlanui.dll is the Wireless Lan User Interface GUI.
  6. Go to Computer Configuration\Policies\Administrative Templates\System\Group Policy and set the “User Group Policy loopback processing mode” to Enabled and select Replace which will override any other policies this software policy will take precedence.

Source: Direct quote from Technet forum post

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.