2

I've had working script, which suddenly doesn't works. It contains something like this:

while read url;
do
    curl $url
done < links

links file:

http://duckduckgo.com
http://google.com

And I get couldn't resolve hostname error.

curl: (6) Could not resolve host: google.com
curl: (6) Could not resolve host: duckduckgo.com

But, when the loop is removed, it works so it's not a network problem.

url="http://google.com"
curl $url

I've been looking into this whole day and I believe it is some stupidity but I wasn't able to figure it out. (quotes tried)

  • Your script works fine for me. Is there something else about the environment you're running under that might be missing? – Joel Taylor Sep 11 '13 at 17:19
  • I've no clue. Using Arch, recently did upgrade (pacman -Syyu) – Lukasik Sep 12 '13 at 6:29
  • 1
    Have you edited your links file since the last time this worked? Is there any chance that you got invisible characters (like carriage returns) in there? Try read url < links; curl $url (should do the first line only). – Scott Sep 12 '13 at 21:55
  • Yes, it is output from another script. Your example doen't works. I tried it in fresh install of xubuntu in virtual and got the same result. – Lukasik Sep 13 '13 at 9:37
  • The issue must be with your links file. I tried Scott's example and didn't have any issue when using my own, hand-crafted links file. Have your tried your script with a custom links file? – Joel Taylor Sep 13 '13 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.