Because of a two-steps deep problem, I need to boot into an EFI shell and run gptsync. I downloaded the flashdrive binaries of rEFInd 0.7.4, used dd to write the image to a thumbdrive, and it seems to boot fine. However, when I select the little shell icon to boot, it flashes to the shell UI and hangs with the following text on the screen:

Starting shellx64.efi
Using load options ''

And that's it. Am I supposed to configure something to get the shell working?

  • It should be working now; however, I altered some details of how rEFInd launches EFI binaries with version 0.7.4 to fix some problems. (I'm rEFInd's author.) It's conceivable that these changes are causing problems for you. Thus, I recommend you try version 0.7.3 and report back. If 0.7.3 works, I'll look into re-revising the launch process to work around the problem. – Rod Smith Sep 11 '13 at 21:48
  • 1
    I tried with 0.7.3 with the only change being this line: Using load options ' ' (a space instead of an empty string). – Ben Collins Sep 11 '13 at 21:58
  • Progress n. An inch at a time – Ярослав Рахматуллин Jan 3 '14 at 20:29

This is most likely an incompatibility between the EFI shell you're trying to run and your computer's firmware. I recommend you try other EFI shells. One that comes with rEFIt is most likely to work on Macs (especially older ones), but there are a number of additional links here and elsewhere. (Try doing a Web search for "EFI shell binary" or something similar.)

Unfortunately, every EFI shell binary I've run across has problems on some computers, so providing one that's universally usable seems to be difficult or impossible. Note that Macs have 1.x versions of EFI, which means they're most likely to work with the older EFI shell v1 rather than the newer v2

  • What worked for me on a Mac was downloading the rEFIt tarball from: refit.sourceforge.net, extracting, and copying shell.efi and gptsync.efi to /EFI/tools. Enable the shell in showtools in refind.conf. Then, from rEFInd, launch the EFI shell, run "fs0:" where 0 is the index of the EFS partition where the /EFI/ is, cd into /EFI/tools and finally run "gptsync.efi". – igordcard May 20 '18 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.