I am using a Samsung LED TV (native resolution 1920x1080), as my computer monitor connected through HDMI. The OS resolution is set at 1920x1080 and the NVIDIA driver reports the same. The computer is a desktop with the NVidia GTX 680 graphics card and only has this one screen connected to it.

However, some programs including Steam and some games seem to think the resolution is lower.

Plus recently, I was writing a graphing tool and was surprised to see that the resolution is being reported as 1536x864 when I try to access it programatically!

The above resolution also seems to be what Steam assumes and does not maximize beyond that point.

Please note that this behavior was the same when I had Windows 7 on the same configuration. Have now installed 8.

Samsung has not been helpful. Any ideas?

  • 2
    Hmm... External Display... this wouldn't be a laptop you are connecting the TV to, would it?
    – Bon Gart
    Sep 12, 2013 at 7:39
  • Because if it is a laptop, then it is entirely possible that the LCD panel that is part of the laptop is set to a resolution of 1920x1080, while the second display (the TV) connected to the HDMI port is set to a different resolution, namely 1536x864. I would go into your NVidia Control panel -> Change Resolution -> and you should have two displays you can pick from to change resolutions.
    – Bon Gart
    Sep 12, 2013 at 7:50
  • @BonGart: No, this is a desktop with the nVIDIA GeForce GTX 680 graphics card connected to the Samsung UA557500 via HDMI. Sep 12, 2013 at 7:51
  • Then I'll change that tag... is this the only screen you have connected to it?
    – Bon Gart
    Sep 12, 2013 at 8:00
  • @BonGart: Yes, this is the only screen. Sep 12, 2013 at 8:03

2 Answers 2


Check DPI Settings, make sure to have selected the default value and enabled the checkbox "Let me choose one scaling level for all my displays".

Restart Steam, it should now display your real native HDTV resolution.


  • 1
    Although this may answer the question, you should give a more detailed description of the linked content and explain how it relates to the question. This will help ensure that this answer remains useful in the event the linked page is removed or goes offline. For more information, see this Meta Stack Exchange post.
    – bwDraco
    Jul 5, 2015 at 17:46

In my case, the TV was not detecting in Windows 10 display settings, but in Windows 7, I was able to see the TV in the display settings. Also, the HDMI connected LCD was showing Red, Blue and Green dots across the display. I tried two ways to solve this thing. Make sure you have latest driver of the Graphics card installed.

  1. If you are in Windows 7, lower the resolution in display settings and check if it works. You have to match the display setting of your Monitor. If your TV is full HD and monitor is only HD or has 1360x768 resolution, make sure you select the same resolution in display settings.

  2. If you are in Windows 10, you wont be able to detect the TV in the display settings, if it detects, apply the same method as mentioned above. If not, then go to control panel of your Graphics card (in my case it was NVIDIA) and head on to Change Resolution option. There you would find an option like Output Color Depth. Lower it and the problem would be solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.