49

Just reinstalling 7-Zip (v.9.2) to a new system, and I cannot find the context-menu option in Explorer. In the 7-Zip options there is no plugins tab (as detailed in the documentation) to change this setting. Any idea how to get the option Explorer functionality working? I'm on Windows 7 64 bit.

12 Answers 12

50

First you need to start 7-zip "as administrator" the first time you run it to assign the context-menu option. Otherwise 7-zip does not have the right to change anything. (I don't know why 7-zip does not do this during install when it already has admin-rights but i always need to do this after installing 7-zip)

Then go to Extra / Options. In the first tab (System) you can choose what files you want 7-zip to associate with and in the second tab (7-zip) you can choose the context-menu option (first checkbox).

5
  • 6
    Thanks Rik but this doesn't work for me. I've ticked all the file associations and they are now remembered after reopening the application. The integrate 7-Zip.. and cascaded context menu options are ticked. But still no 7-Zip options appear in Explorer.
    – geotheory
    Sep 12, 2013 at 15:08
  • 8
    Are you using the 64-bit variant of 7-zip?
    – Rik
    Sep 12, 2013 at 15:12
  • 1
    I was, but I must've loaded it on top of a 32 bit version (which I thought was 64 bit!) when I tried reinstalling earlier. I just checked registry and there were 2 versions running - hence conflict. Have reinstalled 64 bit and now works ok. Thanks for the pointer.
    – geotheory
    Sep 12, 2013 at 15:17
  • Try rebooting. If that's not possible, kill explorer.exe in Task Manager. Restart the process by typing explorer.exe via the run box (File > New Task (Run...)).
    – happy_soil
    Sep 12, 2013 at 15:21
  • 5
    Got it- I was installing 32 bit on a 64-bit machine. No reboot needed. May 9, 2014 at 3:36
53

You are probably using the 32bit version on a 64bit OS. Uninstall it and install the 64bit version. I have done this several times and that solution works for me.

4
  • 4
    Thanks, the solution is working for me on Windows 8 Pro 64-bit running 7-zip 9.22 x64. But in addition, I was running the 7-zip x64 installer as Administrator (using Ctrl+Shift+Enter while clicking on the installer executable file.)
    – Aryo
    May 5, 2014 at 7:37
  • 2
    well done! Working for me as well.
    – ZeroCool
    Nov 2, 2014 at 13:45
  • Simply superb, you nailed it..:) Apr 12, 2019 at 2:53
  • Couldn't get the free 64 bit version on Microsoft Store, but got it from www.7-zip.org
    – Yster
    Nov 24, 2020 at 0:34
13

If you're using the correct bitness of 7zip and have the correct settings set but it still doesn't work, then it may be that the wrong Explorer shell extension is enabled.

It turns out that even with 64bit 7zip installed you can end up with 32bit shell extension enabled, possibly a hangover from previous 32-bit install.

To fix this:

  • Download and unzip ShellExView (x64 version) from the NirSoft website
  • Run it and make sure Options->Show 32-bit Shell Extensions is ticked
  • Sort by Description column and look for 7-Zip Shell Extension
  • If you find 7-zip Context Menu extension and the Filename column shows 7-zip32.dll and it is enabled, then you should right-click and Disable selected items

  • Then untick Options->Show 32-bit Shell Extensions and find the 7-zip Context Menu extension again (filename should be 7-zip.dll) and enable it, this is the 64-bit one.

  • Then close all explorer windows, click Options->Restart Explorer and then open a new folder window and right click on a zip file
  • Assuming the 7-zip settings and associations are set up, the context menu should now show!

This was the only thing that worked for me. Even using the 64-bit version of 7-zip, and running the installer as admin, and running 7zip as admin & changing the settings, it still didn't work until I did this.

1
  • In my case, 7-zip.dll was missing (7-zip32.dll was present though), found that using ShellExView, re-installed and it is fine now... Oct 3, 2016 at 14:53
7

I ran into the same issue with missing 7=Zip context menus on a 64-bit system. Had first installed 32-bit and later 64-bit and kept trying to enable the context menus and they did not appear.

I resolved this from Windows Programs and Features by: 1) uninstalling the 32-bit version 2) selecting Repair on the 64-bit version

1
  • Confirmed. This works.
    – Aloha
    Mar 28, 2016 at 11:21
2

I had the same issue.

The 7z920.exe file contains the x86 and x64 installers -> I couldn't make it work.

I downloaded the 7z920.msi file which contains only the x64 installer and worked like a charm.

1

I had the same issue with chocolatey's 7zip package. The solution was pretty simple:

  1. choco uninstall 7zip
  2. choco install 7zip

Then, the menu was back in place. Since the installation by chocolatey is non-interactive, it took approx. one minute.

1

If you're having this issue in a OneDrive folder, the files you're trying to zip must be stored locally (have the green checkmark), not in "the cloud" (the cloud icon).

That was my issue anyway

1

Here is how it worked for me:

STEP 1: Search "7-Zip File manage" and run it as administrator (right click and you'll see the option)

STEP 2: Click on "Tools > Options > System"

STEP 3: press CTRL + A to select all the type and hit "+" button and click "apply"

If it don't work then you are probably using the 32bit version on a 64bit OS. Uninstall it and install the 64bit version and repeat above process.

Link: https://www.7-zip.org/download.html

Hope it helped :)

0

I received error "7-zip cannot load 7-zip.dll" when tried Rik's method.

My solution was to uninstall and then reinstall.

My laptop was running Windows 7 SP1 32bit so my 7-zip installer is 7.20 32 bit version.

0

Try a new version to install. I use this one and it works for me. http://www.7-zip.org/a/7z1602-extra.7z

0

In my case I have missed 7-zip context menu only on folders (Windows 10 64-bit). To fix it you have to just enable these settings (run 7-zip as user, not admin): enter image description here

Also there are some workarounds for Windows 10 64-bit at #1530 No contextmenu in Windows 10

-3

I fixed this by installing 7zip x64 instead of x32.

1
  • 2
    this was already answered by Jay Elbee above. The reason is because 64-bit processes can't load 32-bit DLLs
    – phuclv
    Jun 24, 2019 at 1:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.