All of the solutions to enable pressing a key while dragging the mouse involve disabling palmcheck. The problem is that palmcheck is extremely helpful. Is there a hack to keep palmcheck enabled and at the same time allow me to use the keyboard? This seemed to work for me on Windows 7, but when I upgraded to 8 and installed the latest synaptics drivers it became one or the other.

  • 1
    Can you go back to the old drivers ?
    – harrymc
    Sep 16, 2013 at 18:51
  • i can go back to the old drivers but that effects scrolling and other features.
    – Gil Birman
    Sep 17, 2013 at 6:48
  • Do you have the OEM supplied drivers designed for your specific system, and for Windows 8?
    – zeel
    Sep 17, 2013 at 14:29
  • @zeel there are no OEM drivers for windows 8
    – Gil Birman
    Sep 17, 2013 at 18:05
  • Then it may be impossible to fix at this point. Touch-pads are finicky, each one is customized for a specific laptop, thus generic drivers will not always work properly, and drivers intended for other OS versions will not always work properly. You should contact your manufacturer and see if they plan to release a driver. If not, then you may want to look for third party software.
    – zeel
    Sep 17, 2013 at 21:55

8 Answers 8


The problem is that Synaptics "palm check" is not your problem. Palm check detects that your hand is resting on the touch pad, and will not intemperate that as an attempt to move the mouse.

The problem is a setting in windows 8 that disables tapping while typing. However the correct driver should automatically disable this, and use palm check only.

Make certain that your driver is in fact up to date. Make sure you get the latest driver from the manufacturer that is intended for your laptop and for Windows 8. If no driver is offered for Win 8 try the Win 7 driver, or the generic driver from http://www.synaptics.com/resources/drivers. Be sure to fully remove your driver before installing another version. If there is no Win 8 OEM driver for your device, and none of the others work either, then you can try disabling the setting manually:

Unfortunately I can not seem to find the location of the setting! It's easily accessed in 8.1: Open the charms menu, select settings > "Change PC Settings" > "PC and Devices" > "Mouse & Touchpad" and disable the taps delay. But I can not locate the same setting (which may have a different name) in normal Windows 8.

If the setting is grayed out (or otherwise impossible to change) then you may need to remove your drivers, disable the setting, then re install them.

If it still doesn't work, then I am afraid you will need to contact your laptops manufacturer for assistance. They may release a new driver in the future, or it may not be possible to fix. In the second case, there may be third party software that can help you.

At least that's how I got it to work when I had a similar problem. Though soon after fixing it a new version of the driver was released that not only would have fixed it, but made it work even better. YMMV

  • I've tried these suggestions, except for disabling the taps delay. I don't know where that is and could not find it per your instructions.
    – Gil Birman
    Sep 17, 2013 at 6:49
  • Oh. . . I'm sorry, I forgot that my system is running 8.1! There is still a similar setting in 8, I just can't figure out where. I know I had the same problem as you, and managed to fix it, but I can't remember where the setting was. . .
    – zeel
    Sep 17, 2013 at 14:22
  • Thank you zeel, this has been bugging me for ages -- when you need to hold a key + click for an action, I could not get it to work for the life of me. The strange thing is, with the setting disabled, holding a key while trying to move the trackpad results in some, stuttery movement. Better than nothing, I guess?
    – James B
    Mar 13, 2015 at 8:31

In a similar post - Use touchpad while “typing”? - the following answers were proposed.

Disable/reduce SmartSense

This described in detail in How to Turn PalmCheck On or Off for Touchpad in Windows.

  • Open Control Panel -> Mouse
  • Click on the TouchPad Settings tab, then on ClickPad Settings.
  • Double Click "SmartSense"
  • Slide the Slider all the way to "Off"
  • Click Close and OK.

The article Prevent Touchpad From Being Disabled by Keypresses says further:

Although it doesn’t mention disabling the touchpad while typing, it in fact does do this while set above 50%.

I recommend setting it to around 50%, or have a play around to find what works best for you. You can test whether the touchpad is still being disabled easily by selecting a new value, then holding the Tab key and attempting to move the touchpad. If the touchpad stops responding after a couple of seconds, the PalmCheck setting is still too high.

Registry update

In the Registry, go to the key HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Defaults, and set the value of all string entries of the form PalmKms…, to 0. (Of course, they probably don't all need to be 0, but have fun finding out which one(s) you actually need!) These values determine the amount of ms that the touchpad stays disabled after keyboard input has been detected.

  • these suggestions don't work. also I don't have the PalmKms registry keys, those are probably for an earlier version of the drivers.
    – Gil Birman
    Sep 17, 2013 at 7:28
  • For some Synaptics version the slider is found in : Control Panel / Mouse / Device Settings / Settings / Pointing / Sensitivity.
    – harrymc
    Sep 17, 2013 at 15:07
  • For some reason, running taskkill /f /im SynTPEnh.exe made the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP show up. If you are unable to see the PalmKms keys, try running the command and then check the registry. Apr 8, 2020 at 13:31

I am not 100% sure it will help, since I don't have a laptop with a Synaptics touchpad, so I can't test this application. But try TouchFreeze, it's free.


harrymc's solution works for me. I made .reg file for setting it, as it's reset sometimes. Be aware I'm using 32-bit and I don't guarantee it's the same on 64-bit.

.reg file open it in notepad and see

set all PalmKMS** to 0

  • Thank you! The .reg file works perfectly for my touchpad (v17 driver), even though the PalmKMS keys weren't there in the first place. Applying it and manually restarting SynTPEnh.exe does the trick.
    – Andy C.
    Jul 30, 2016 at 16:03
  • Also, you can actually turn palm rejection on after applying this to get the best of both worlds.
    – Andy C.
    Jul 31, 2016 at 9:30

Ok, so, I just had this problem with my Lenovo Ideapad S145, which uses the synaptics touchpad and I managed to fix it, I can tell you for a fact that it DIT NOT require any registry changes since I did none.

My fix involved COMPLETELY unninstalling any touchpad drivers from my machine, so it actually made so my touchpad became unusable for some time, I imagine you can plug in a external mouse but I did not had to, just make sure you can navigate using the keyboard only before trying this.

First, download the latest touchpad driver from yout OEM (lenovo in my case). Than, go to Control Panel and find the "Mouse" options, than go to Hardware, click on your Synaptics driver and click "Properties", then Alter Configurations (or something like that), Driver, and Remove Device, your pointer might become stuck, so restart the machine via start button or some other means.

Do this UNTIL THERE IS NO OTHER DEVICE IN THE HARDWARE SCREEN, not even the default windows one, then install your previously downloaded synaptics driver, restart again, and it should work perfectly.

I hope this helps someone, but be aware that it might not work for you, and if you can't install your drivers without using the touchpad you might become stuck!


None of the solutions offered by others solved the issue very well. Using the old Windows 7 drivers did work in Windows 8 but then other features were absent, such as two-finger smooth scrolling. When I was on Windows 7 with the old drivers I had used a utility called TwoFingerScroll which solved this problem for me, but it does not work on Windows 8.

In the end, the way I actually dealt with the problem was to disable PalmCheck AND to disable tapping on the touch pad. Both are options in the Synaptics control panel. Now, even though my palm might move the mouse it does not cause the click which was driving me crazy before.


When using Synaptics Touchpad:

  1. Go to contol panel then go to mouse settings (Mouse Properties).

  2. Open the last tab (Device Settings) and in the center right there should be a box that says 'settings...', Click on that and it brings up 'Properties for Synaptics TouchPad V7.5 on PS/2 Port' (for me).

  3. Open the '+' next to 'Pointing (3rd one down), then 'Sensitivity' (1st one in pointing) and go to 'TouchCheck'.

  4. Slide the slider to Minimum for enabling the touchpad while typing (for games or productivity, etc. ) and to Maximum when wanting no touchpad when typing (accidental palm, etc. ). This is what worked for me.

I am using windows 8.1


On many touchpads there is a setting in the drivers you can access by opening Run, typing in "regedit", and then navigating to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control. Somewhere is a setting called something like Disable Touchpad While Typing, which you can change the value to 0. It's a mess in the registry though. I'll update this if I find it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.