29

It's just annoying. I know what happens on my system and if I want to check a software, I can do it on my own. Though I don't know how to disable that. Turning off every notification panel doesn't change a single thing. Turning off notifications doesn't change anything. Does anyone have a solution ?

6
  • 1
    I have this problem whenever I click on a link on any application other than a browser. For example, in a mail application, I click on a link, and instead of a browser appearing, I get this notification. I can't understand why it would be desirable to have a notification instead of the actual browser open...
    – kapace
    Nov 6, 2014 at 19:09
  • Well the fact that when you disable notifications, those still appears annoys me to the highest possible point.
    – Depado
    Nov 7, 2014 at 14:10
  • related
    – bummi
    Nov 7, 2017 at 15:03
  • Appears to be caused by one of your windows having "always on top" set, even if it's minimized. Mar 13, 2020 at 10:53
  • 1
    This is back and it's driving me mad. When I click on a text document I clearly want to open it, not have a damn silly message telling me that it's ready. Or when I click on reconcile in gnucash, I want to go direct to that window. I'm running 21.04 and this has only just started happening, so either it is a result of a software update or I've inadvertently changed my settings, but if the latter I've no idea how. Oct 6, 2021 at 20:45

8 Answers 8

4

There is a gnome shell extension called Steal my Focus which disables this behavior but it doesn't seem to be supported by the developer anymore. You can make it work though by forking the git repository, editing the metadata.json file and adding your gnome-shell version in there. Here is mine:

{
    "_generated": "Generated by SweetTooth, do not edit",
    "description": "Let windows steal focus. Removes the annoying 'Window is ready' notification and focus window immediately",
    "name": "Steal My Focus",
    "original-authors": [
         "kagesenshi.87@gmail.com"
    ],
    "shell-version": [
         "3.2","3.5.2","3.6","3.6.2","3.7","3.8","3.10","3.10.1"
    ],
    "url": "https://github.com/kagesenshi/gnome-shell-extension-stealmyfocus",
    "uuid": "steal-my-focus@kagesenshi.org",
    "version": 1
}
3
  • 1
    Though I don't want the window to auto-focus. I just don't want to get notified. (Because it's just annoying) Is there a way to modify that extension so that it doesn't focus ?
    – Depado
    Oct 21, 2013 at 14:30
  • It is but I don't have the knowledge to mofidy it myself. I understand JavaScript but I don't know much about Gnome Shell's JS API Oct 21, 2013 at 15:20
  • 1
    Yeah me neither xD I'll just deal with it or wait until Gnome Developpers update the Notification stuff. Thanks for your help. I'll validate your answer.
    – Depado
    Oct 23, 2013 at 7:46
12
gsettings set org.gnome.desktop.wm.preferences auto-raise 'true'

For anyone viewing this question recently, and willing to accept the newly opened window to rise on top of other open windows.

4
  • This worked for me on Pop!_OS 20.04 / gnome 3.36.8. Jan 12, 2021 at 7:32
  • Yes, this is the one, thanks.
    – Ista
    Apr 7, 2021 at 19:33
  • Unfortunately, it seems this doesn't solve it on Debian 11 / GNOME 3.38.6.
    – Seth Falco
    Jul 23 at 18:53
  • Nope, with GNOME 43 I still get the 'window is ready' notifications, and the window is not in focus. NoAnnoyance v2 as mentioned in a different answer solves it as far as I can see.
    – TeNNoX
    Oct 26 at 21:14
10

The answer I arrived at is to install this Gnome Extension:

https://extensions.gnome.org/extension/1007/window-is-ready-notification-remover/

Discovered while participating in this issue:

https://github.com/signalapp/Signal-Desktop/issues/3321

1
  • Best solution since it does not modify any other behaviour; it just disables the notification. Jul 5, 2021 at 12:50
5

In Gnome 3.18, there is an option in gnome-tweak-tool to automatically focus on the window instead of displaying this annoying notifications.

3
  • 15
    Could you clarify which option this is? Nov 22, 2018 at 12:08
  • Works on Ubuntu 20.04.
    – ikurcubic
    Dec 4, 2020 at 16:16
  • 2
    Not found in gnome-tweak with Ubuntu 20.04 Jan 7, 2021 at 13:38
3

Here is a similar extension that works on newer versions of gnome-shell (tested on 3.16) https://extensions.gnome.org/extension/1005/focus-my-window/

3

You're observing GNOME's focus stealing prevention kicking it. A background app wants to steal the focus (i.e., put one of its windows in focus) but GNOME's heuristics determine that the request is not based on a current user interaction, so the currently focused window should keep its focus.

This GNOME extension will mute the notification:
https://extensions.gnome.org/extension/1007/window-is-ready-notification-remover/

If you instead would like to disable focus stealing prevention, i.e., you want the window mentioned in the notification to actually get the focus, then use this extension instead:
https://extensions.gnome.org/extension/2182/noannoyance/

For more background: https://gitlab.gnome.org/GNOME/mutter/-/issues/673

(The above comment was written by user real-or-random as a replacement for my answer - and then reverted back - when it should have just been added as another answer. I am posting it on their behalf so it's not lost.)

1
  • this ones great. Recently switched to gnome3 and this popup problem just saved me a nightmare. Thanks May 25 at 12:54
2

I've found another half-measure: another extension which is not stealing focus, but providing a keyboard shortcut for showing the "ready" application/dialog: https://github.com/awamper/window-demands-attention-shortcut

Default shortcut is Super-W and it is configurable in gnome-tweak-tool.

1
  • It worked with Ubuntu 17.10
    – Anwar
    Dec 29, 2017 at 15:55
0
  1. Use dconf-editor
  2. Set property "/org/gnome/desktop/wm/preferences/focus-new-windows" to "strict"
  3. Apply changes
  4. Enjoy
1
  • 1
    this just removed notification.... but window still not showing up... :(((
    – zb'
    Aug 9 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.