108

While trying to quit the GIMP image editor, I inadvertently clicked the cross on the main toolbox (the one with selection/painting tools, etc). Now, the toolbox seems to be permanently lost, even after restarting. Is there anything I can do to get it back, or alternatively, how can I reconstruct it?

I'm using version 2.8.2 on Windows XP, with the multiple window layout.

  • 1
    Can you please tell us what version of GIMP you are using, and more importantly if you are using Single-Window Mode? – Drew Chapin Sep 15 '13 at 5:58
  • I've added the info to my question. Thanks for informing me that a single-window mode exists! – mwfearnley Sep 15 '13 at 16:50
129
+50

There are two possible solutions I can see:

  1. If the GIMP session is still open, restore the toolbox you just closed by going to Windows -> Recently Closed Docks, and it should be there in the list. Windows -> Recently Closed Docks -> Toolbox - Tool Options

  2. Otherwise, go to Edit -> Preferences in the Window Management section, and press the Reset Saved Window Positions to Default Values button. If you customised either of your palettes (or added new ones), then this method will lose those changes. Edit -> Preferences -> Window Management -> Reset Saved Window Positions to Default Values

To prevent this happening in future, you can uncheck the Save window positions on exit checkbox (same page), so the toolbox always reappears when you restart GIMP, no matter if you closed it earlier or not.

  • I was having trouble getting #2 to stick, but it seemed to work if I did it while no image was opened. – fmoo Sep 8 '16 at 17:13
  • 1
    +1 Thanks, this helped! Somehow I accidently made my image take up the whole screen, and all the side toolboxes docked disappeared. Your technique helped, but any idea what key combination caused the enlargement accompanied by loss of toolboxes? thanks! – Eric Hepperle - CodeSlayer2010 Feb 2 '18 at 15:04
20

This is what the default dialogs look like:

GIMP Toolboxes

The main Toolbox is actually quite easy to recreate - it's just the Toolbox dialog (you can create a new one with Ctrl-B or Windows -> New Toolbox if you don't have one), with a Tool Options tab beneath it. Resize the toolbox until a space appears beneath it where you can drop dockable dialogs, then goto Windows -> Dockable Dialogs -> Tool Options, and drag the new dialog's tab into the space.

The other dialog contains four tabs in the top pane: Layers | Channels | Paths | Undo

and three in the bottom pane: Brushes | Patterns | Gradients

Start with the top pane: open the Layers dialog, then open up the Channels/Paths/Undo dialogs (from Windows -> Dockable Dialogs) and drag their tabs in next to the Layers tab.

Then to create the bottom pane, open the Brushes dialog and drag its tab to the very bottom of the dialog window (just above the window border), and the dialog will split into two panes with Brushes at the bottom. Patterns and Gradients can then be opened and dragged into the bottom pane.

11

Pressing TAB is the toggle for Hide Docks. Which totally removes the toolbox from view. It's very easy to hit on accident. Try this to see if you've hidden your toolbox.

10

From the GIMP menu select Windows -> Toolbox and the Toolbox window will reappear.

  • 1
    On my version (2.8.2), I see Windows -> New Toolbox (Ctrl+B), which produces a thin vertical palette of the tools, without any of the additional palettes. I see also Windows -> Recently Closed Docks, but it's empty. – mwfearnley Sep 15 '13 at 16:54
  • In the lower right-hand corner of the Toolbox window there is a blue button surrounded by a yellow arrow that says if you mouseover it: "Reset to default values Shift Reset all tool options". – karel Sep 15 '13 at 22:24
  • 1
    The accepted answer of resetting the preferences did not work for me on OS X version. Thank you for the simple solution. – Douglas.Sesar Nov 14 '14 at 15:51
3

You might need to click Windows -> Hide Docks:

Screenshot

0

For GIMP 2, when I installed 2.8.18 on Windows 10, there wasn't even a ToolBox showing, and I couldn't find how to enable it in View or Preferences.

I'm not sure if this is a bug, but if it's not it's a terrible default-UX.

Anyway, if you're in the same boat, just go to your action bar at the top and select Windows -> New ToolBox

There! Now you aren't using a visual editor relying on menu traversal and keyboard shortcuts...

Not the answer you're looking for? Browse other questions tagged or ask your own question.