5

I have a 2 GB SanDisk MicroSD card.

I normally use this card in my Nikon camera but ever since I used it in a Brother printer, I cannot delete any of the files, write or format the card.

I've searched online, including SuperUser, but my problem seems unique in that I do not get any errors when deleting, writing or formatting card.

Nikon Camera: Everything appears normal when using this card taking pictures... no errors when supposedly saving the photo. However, when trying to view pictures, the camera reports that none can be found. I can do a "Quick Format" within the camera'a Setup screens but the card is not formatted and no errors reported.

Brother Printer: Scanning direct to this MicroSD card. (this is the incident that "broke" the card) First document scanned fine. Every subsequent attempt since then always gives an "Out of Memory" error.

MacBook: I am manually deleting the files without errors, but the next time I insert the card, the files re-appear.

SDFormatter: I downloaded and installed the latest version of SDFormatter (v4.0 Mac) from sdcard.org. I am doing a "Overwrite Format" option, I get no errors, and the format completes with a success message. However, all of the original files remain on the card!

I am using a MicroSD to USB adapter with the MacBook and a MicroSD to SD card adapter with the Nikon.

Clearly, based on all observations above, I cannot write to the card. Weirdly, with the exception of the Brother, I just don't get any errors when writing.

It's like the card is locked, even though it cannot be locked without the hardware lock on the SD adapter, and I never get any "write protection" errors.

I suspect that a corrupted MicroSD card is the root problem, but here are my questions:

  1. Why would I not get any errors when writing, deleting or formatting?

  2. What can I do or use to verify the hardware integrity and/or fix this card as needed?

13
  • 2
    SD cards do break; sounds like this one has. Sep 15, 2013 at 19:24
  • Suggest you to use a recovery software (Recuva is a good choice) to get what you can from the card, then trash it. Get a new one.
    – ADTC
    Sep 15, 2013 at 19:35
  • 1
    @ADTC, luckily, there is nothing to recover.
    – Sparky
    Sep 15, 2013 at 19:37
  • 1
    I agree here. It sounds like the card is just bucked. Good job you don't have anything that needs to be recovered. :) Sep 15, 2013 at 19:39
  • 3
    @ADTC, I'm done with it. SDFormatter (Windows) completes a full format without errors... still no good. Windows built in format option is giving errors: "Windows was unable to complete the format" for all three file system options. Pretty conclusive as far as I'm concerned. Thanks for the help.
    – Sparky
    Sep 15, 2013 at 19:46

5 Answers 5

5

I installed the Windows version of SDFormatter, and although the options are slightly different than the Mac version, the results are the same. Format appears to complete but yet the card is untouched.

Then I tried the Windows built-in format option and it's giving the "Windows was unable to complete the format" error for all three file system options.

The card is toast as far as I'm concerned.

Thanks all for the help.

3
  • You did ask why you wouldn't get any errors when trying to write to the card, and what you could do to verify its integrity on a hardware level. I'm curious about those, myself. Sep 15, 2013 at 20:02
  • @BlacklightShining, yes, true, but there will also be two full days for somebody else to post a better answer before I can accept this.
    – Sparky
    Sep 15, 2013 at 20:05
  • Just had 64GB Sandisk card fail the same way - the underlying storage seems set to read only. I can write to it, but nothing persists! Drove me nuts for a while until I figured it out. I could write garbage to the whole thing without affecting the filesystem… weird stuff.
    – MikeyB
    Sep 12, 2015 at 5:28
2

I just had the same issue. I tried:

  • Three different micro-SD card readers (a USB 2.0, a USB 3.0, and a micro-to-SD adapter)
  • About a dozen different partition utility tools
  • Both Windows and Mac

Other microSD cards do not have the same issue.

The tl;dr is that all of them had the same result. It seems the card is hosed and you need to buy a new one.

0

I had an SD card that I thought was broken and nothing I tried worked. As a last resort I purchased an SD card to USB adapter and I was able to Format the SD card from within windows. It has been working perfectly ever since.

3
  • Yes, as mentioned, I already have a USB adapter for this card. I am presently trying the Windows version of SDFormatter to see if it makes any difference.
    – Sparky
    Sep 15, 2013 at 19:39
  • Ah, ok. Yeah, try the windows version and see if that helps.
    – Yass
    Sep 15, 2013 at 19:40
  • SDFormatter (Windows) completes a full format without errors like the Mac version. Windows built-in format option is giving errors: "Windows was unable to complete the format" for all three file system options. It's toast.
    – Sparky
    Sep 15, 2013 at 19:48
0

Just in case,

I had the exact same problem (phone and devices could format but it didnt do anything) and it also didn't work with my usb adapter for windows.

BUT it worked with another card reader on windows. With that device I was able to remove files and format.

1
  • Thanks for contributing your experience. Super User isn't a forum, its purpose is to build a knowledgebase of questions and answers. For this format, it better for each answer to contribute something new in order to keep the information concise. Yass had already provided this solution, so another similar answer isn't needed. Confirming that a previous solution worked can be done with an upvote or comment (which both require a little more rep).
    – fixer1234
    Apr 12, 2015 at 19:10
0

Just faced the same issue with a 32GB SD card. Video recording device would not give any error messages upon trying to format, nor show any files but say no free space available. Windows couldn't format it either - "Windows was unable to complete the format". After a few tries, Windows Explorer now showed as 2 different drives, with 29GB and 100MB space. diskpart steps on this question helped with deleting clean the partition I never created: How do I fix my SD card after it was split into multiple drives by Windows loT core?.

On Step 5, Windows Explorer still wasn't able to format the cleaned drive. So, the following steps helped resolve that:

  1. select disk x (X is disk number from previous command)
  2. create partition primary
  3. Windows Explorer was now able to format using default allocation size.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .