When I type http://www.google.co.uk in the URL bar Firefox rewrites it as https://www.google.co.uk. This is a problem for me as HTTPS is blocked on my network for content filtering purposes.

Until a few days ago this was not the case, but during some experimentation I seem to have visited the HTTPS version of the site once or twice and also had the HTTPS Everywhere addon installed for a time. Now, no matter what I do Firefox redirects there. Sometimes it doesn't; sometimes I load the browser and the HTTP version loads fine, but then the next time it's oddly trying HTTPS again and nothing can shift it until a few session restarts later. I don't understand why it seems to sporadically use HTTP and HTTPS.

I'm using Firefox 23.0 and Ubuntu 12.04.

I've tried a number of things so far:

  1. Setting browser.urlbar.autoFill false, browser.urlbar.autoFill.typed false, browser.formfill.saveHttpsForms false
  2. Clearing everything from history
  3. Resetting Firefox and using safe mode
  4. Deleting all the profile data in .mozilla folder and creating a new profile
  5. Completely purging Firefox and deleting .mozilla, /etc/firefox and reinstalling

How can I fix this so that Firefox just loads Google in non-HTTPS?

Maybe it's Google doing the redirect, but I just don't understand why it was fine until a few days ago, and also why it only does it sporadically.

Even when I try typing in nosslsearch.google.com I get redirected to the HTTPS version!

Lastly, when I log into another user account on the computer, and try Firefox with Google I see no problems with redirects, just as it had always been until recently on the above account.

EDIT: I should also mention I am not logged into any Google account.

  • What if you try ? This is the IP for nosslsearch.google.com. I tried it (always logged in with Google) and got to a non-signed in http Google page. – Rik Sep 16 '13 at 12:51
  • @Rik that does seem to work. Interesting. Why? – fpghost Sep 16 '13 at 14:28
  • 1
    You can always add google.com www.google.com in your hosts file so you always get to the http and you never use the https variant. It's not perfect but works. I don't know why it's happening in your user-account and not another. – Rik Sep 16 '13 at 14:34
  • @ Rik thanks, that will be a good temporary fix at the very least. It could be that Google or Firefox have changed something in the last few days, but for me it seems strange that I also visited the https site and played with https_everywhere extension in the last week too (plus the other account being fine still). Nevertheless, even clean installs of Firefox still bring no joy, so I am lost with what else to try. Alas. – fpghost Sep 16 '13 at 15:02
  • > "HTTPS is blocked on my network for content filtering purposes." — my advice is change your job, seriously. (and if this your home ISP, then it's just pure madness). – Display Name Jul 7 '15 at 18:40

I noticed using Fiddler that sending HTTP requests to Google would always return the 302s you mention, redirecting me to the HTTPS url as long as a Firefox user agent string was included in the request header. This is my current user agent string using Firefox 24 on Windows 7 x64:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

So for me, a simple fix was to start using the User Agent Quick Switch add-on for Firefox. I changed my user agent string like this - just removed the Firefox/24.0 at the end:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101

I'd guess a similar change to your Ubuntu user agent string would also do the trick, although there is an outside chance that it be problematic on another site.


If you are logged in to Google with a Google user account, Google will serve everything in https, so be sure you are logged out of all Google accounts.

  • Yes, I am not logged in or anything. I should have mentioned that --- question has been edited now. – fpghost Sep 15 '13 at 20:50
  • @fpghost Did you try removing the Firefox package through the Software Center, rebooting, then reinstalling? – Paul Sep 15 '13 at 20:59
  • No, not tried via Software Center, just the purge and deletions followed by reinstall. I will give it a go if you think it might make a difference... – fpghost Sep 15 '13 at 21:11
  • I can't say for sure it will fix it, but it's something I would try, especially since so many other changes have been made it may be difficult to get Firefox back to working normally if the problem were otherwise identified. – Paul Sep 15 '13 at 21:13
  • I've now done the remove from the Software Center, along with removing everything I could see relating to firefox in Synaptic Package Manager (marking for Complete Removal). Then I deleted .mozilla,.adobe, .macromedia from ~ and /etc/firefox/, /usr/lib/firefox and /usr/lib/firefox-addons. I then rebooted and reinstalled firefox from the Software Center. Unfortunately the problem still persists. Yet on the other user account things are fine... – fpghost Sep 15 '13 at 22:08

This behavior is determined from the server. If you look the over the request you will find that we are requesting for http://wwww.google.co.in but the response returns https://www.google.co.in with the status code 302. So that means server redirects the http request to https

Here is what I observed in developer console of firefox.

enter image description here

  • I had seen that in the console also. Still I can't understand why this was not happening until a few days ago (it seems too coincidental with me visiting the https site and mucking around with https everywhere, unless it just so happens google made a major change then also). Secondly, I don't see the behaviour on the firefox on my other user account when I visit http google (no redirects there), which makes me think something local must be happening too. – fpghost Sep 15 '13 at 21:39
  • Also if it is the server, why does even nosslsearch.google.com redirect back to https? seems a very odd behaviour. – fpghost Sep 15 '13 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.