18

How can I tell NVIDIA Optimus to always run Google Chrome on my NVIDIA (rather than Intel) card?

The "Run with graphics processor: NVIDIA" option doesn't seem to have any effect, and NVIDIA for some reason seems to disable it in the control panel:

3
  • You should now be able to take the steps you were initially taking. This no longer seems to be an issue, as of 4/19/2017.
    – AP.
    Apr 19, 2017 at 21:42
  • @AP.: Sadly this happened. :(
    – user541686
    Apr 19, 2017 at 21:45
  • The new Chromium based Edge will use the graphics card more readily than Chrome. I can't get any of these solutions to convince Chrome to run on my Nvidia Quadro.
    – Simon
    Oct 8, 2021 at 20:24

5 Answers 5

10

Update

It looks like a newer version of the GeForce driver allows the nvidia card to be selected for chrome.exe

You can check GL_RENDERER at chrome://gpu which should then say GeForce.

===

According to NVIDIA, chrome and firefox both have been disabled from using the Nvidia GPU by design.

This is a death blow to WebGL in web browsers on optimus laptops and I have no idea why they decided to do this.

"Radium3D said: I have an ASUS N53SV laptop which features GPU switching and I have an issue with 326.80 drivers not allowing Firefox or Chrome to use "high performance NVIDIA processor" anymore I only have the option for "integrated graphics" under manage 3D settings -> program settings. I did not have a problem before."

This is by design. We disabled it for other browsers a while ago and forgot to do it to Firefox until recently.

ManuelG

source [geforce.com]

1
25

I figured out a workaround for this, if you create a hard-link to chrome.exe in the same directory, you can set a profile for that executable independently.

C:\Program Files (x86)\Google\Chrome\Application>mklink /H gpu-chrome.exe chrome.exe
Hardlink created for gpu-chrome.exe <<===>> chrome.exe

You'll need to run cmd.exe in administrator mode: right-click, run as admin.. and your Google Chrome application may be in another folder as %USERPROFILE%\AppData\Local\Google\Chrome\Application\

Now I can run gpu-chrome.exe and have full 3D acceleration from my dedicated card.

Just right-click this new .exe and define a new predetermined GPU for running it as you did before nVidia blocked that option.

1
  • This works for me, thanks! Though I always have to edit the profile's launcher icon on the desktop to use that other .exe and also have to start with selecting nvidia gpu from the right click submenu.
    – Ikon
    Dec 30, 2013 at 9:45
5

For recent versions Chrome (80 or so), head to chrome://flags/#use-angle and select OpenGL instead (the default option reads Default and varies by versions, where for Chrome 80 it's ANGLE), then you can right-click Chrome → Run with graphics processorHigh performance NVIDIA processor to get your NVIDIA card running for WebGL etc. Check chrome://gpu to ensure.

At least for me (Driver 445.75, Pascal GPU with Intel Coffee Lake) Chrome never runs on my NVIDIA GPU when using ANGLE even if I set this in NVIDIA Control Panel. Chrome does, however, respect my selection for GPU (either via NCP or right-click context menu) when I choose OpenGL as renderer (as described in the above paragraph).

2
  • Cool, thanks! Also seems available on Chrome 78. I think you meant the default option is Direct3D 11, though. Also, I already have that option in the context menu, so I'm not sure if this is necessary.
    – user541686
    Apr 2, 2020 at 10:34
  • @user541686 The default options reads "Default" and actually changes across versions. At least for Chrome 80 it's ANGLE. Regarding the context menu option, if you don't select a specific GPU to run on then it uses whatever determined in NVIDIA Control Panel.
    – iBug
    Apr 2, 2020 at 17:20
3

Actually this seems to now work correctly (at least when I posted this, May 2017).

In the nVidia control panel, you can select the nVidia card for chrome.exe. Then make sure to fully close chrome by going to the menu > Exit. And reopen it. If you check the GL_RENDERER in chrome://gpu it should say GeForce.

1
  • 1
    Not work for Chrome 80.0.
    – zwcloud
    Mar 7, 2020 at 10:52
1

new nvidia drivers allow running with nvidia gpus, but you still have to run chrome with

--disable-gpu-driver-bug-workarounds

parameters. otherwise backend always uses intel gpu. you can check this on

chrome://gpu 

page and see for yourself.

11/2017 update

Nvidia Control panel on the latest driver allows nvidia gpu to be selected. If now, you can use NVidiaInspector(a third party software) to enforce it.

1
  • This doesn't seem true for me currently - qwertzguy holds true for me. Nov 2, 2017 at 21:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.