5

Around May of this year, I built a computer using the following parts:

• Intel Core i7-3770K Quad-Core processor
• Corsair Vengeance 32GB (4x8GB) DDR3 1600 MHz memory
• MSI Radeon HD 7950 Twin Frozr III 880MHZ 3GB 1250MHZ graphics card
• SeaSonic S12II 520 Bronze 520W power supply
• Plextor 128GB SSD M5S 2.5 SATA
• Western Digital Caviar Black 1TB hard drive
• Gigabyte Z77X-UD3H ATX motherboard

Since building it, my computer has been running perfectly fine with no issues. Recently, however, in the past few weeks or so, it has begun freezing about once every 3 days, requiring a restart. These freezes are completely unpredictable, and can happen when I'm doing anything from browsing the web or playing a game, usually late at night or early in the morning. The screen will continue to display, howeve the mouse stops moving and the keyboard does not respond (caps lock light does not toggle on). The freezes also only seem to occur while I'm using the PC, since I have never found it this way after leaving it idle for hours at a time. Aside from the random freezing, the PC otherwise continues to run with no flaws or hiccups.

I have tried nearly everything I can think of to diagnose and resolve this, including running MemTest, stress tests for the graphics card, making sure all drivers are up to date, using multiple malware removal programs, and downloading a hotfix provided by Microsoft, but none of this has solved the problem.

This is what my Event Viewer looks like right now:

enter image description here (full size)

Anything to help resolve this would be appreciated, thanks.

EDIT 9/21/13: After reviewing the drivers again, I found that one of the VIA HD Audio drivers rolled back without me realizing it, due to a system restore I had to perform. I updated it a few days ago and the issue seems to be resolved for now. Thanks for the suggestions.

EDIT 10/12/13: It seemed to work fine for awhile, but the problem has come back and is worse than before. It crashes a few times a day now and I'm still having trouble finding the source of the problem.

EDIT 10/26/13: Managed to prevent any issues for about 10 days straight by leaving foobar2000 closed. Opened it up again and the computer froze within hours. Since the problem has been occurring before I started using foobar2000 instead of winamp, the computer seems to have issues with any music player, even when the playback is paused. Very weird.

EDIT 10/28/13: Froze without any media player open today. One thing I've noticed is that some of my USB devices (wacom tablet, network adapter) usually stop working before the freeze. No idea if that indicates anything important. Giving this solution a shot: http://www.tomshardware.com/forum/267846-30-devices-freeze-computer#4160168

EDIT 11/6/13: The problem seems to be completely gone now. I took the advice from that Tom's Hardware thread and disabled "Legacy USB Support" on my motherboard's BIOS. (option seen here http://i.imgur.com/AO1TpE8.jpg) No crashes since. If anyone else with a Gigabyte motherboard is having similar issues, this is definitely something you should try.

  • 1
    Did you recently update the BIOS? – Dave Sep 16 '13 at 11:47
  • gigabyte.us/products/product-page.aspx?pid=4153#bios I updated to the latest non-beta version (F18) long before the problem started occurring, would you recommend trying the beta? – durrgh Sep 16 '13 at 11:59
  • try all 5 steps from scenario 3: support.microsoft.com/kb/2028504 – magicandre1981 Sep 16 '13 at 17:48
  • Silly question, but are all the drivers up to date now? I know you said there were but some rolled back... Did you also update the chipset driver? – Dave Oct 21 '13 at 13:22
  • I believe all the drivers are up to date, but I think I'm still using the chipset driver that came preloaded. Anyway, there have not been any freezes at all lately. The only thing I'm doing differently is leaving foobar2000 closed, though I have no idea if that should have any significant bearing on the issue. – durrgh Oct 26 '13 at 0:53
4

There are many reasons for this so in regards to the Kernel-Power critical error you could review,

- turning off turbo boost or dynamic cpu adjustment (BIOS settings)  
- disabling SATA3 (BIOS settings - Most devices arn't SATA3 yet)  
- disabling HPET (BIOS setting - high precision event timer)  
- disabled ATI /AMD event logger (start/Run/services.msc Find the service and disable it)  
- updated drivers (Especially the audio drivers, some older versions of the HD audio can cause crashes)  
- disabled ATI RAID Xpert (start/Run/services.msc Find the service and disable it)  
- uninstalled ATI HD audio drivers (Right Click My Computer/Properties, click on device manager and uninstall drivers for HD Audio)  
- upping the northbridge and ram voltage by 1 or 2 notches (BIOS settings)   
- disable Harddrive Sleep and Hibernate (For Desktop users: In Power Options, select High Performance, Goto Advanced options, select Hard disk, and put 0 Minutes)  


I found that I had two C-Media sound drivers in conflict. My system continually recognized them as USB drivers when I had only one USB sound driver.

Disable Harddrive Sleep and Hibernate (For Desktop users: In Power Options, select High Performance, Goto Advanced options, select Hard disk, and put 0 Minutes)

Restore to the 'old' BIOS if recently updated.

Source

  • After disabling HPET, turbo boost and the HD audio drivers, as well as disabling harddrive sleep and hibernate, the computer quickly produced another one of these errors and froze, so this may have helped isolate the problem – durrgh Sep 16 '13 at 12:45
  • 1
    Audio driver seemed to be the culprit, thanks – durrgh Sep 21 '13 at 10:32
  • Nevermind, the problem is still continuing, even after the HD Audio Drivers have been disabled. – durrgh Oct 13 '13 at 2:28
  • Can you roll back the BIOS driver to an earlier state? – Dave Oct 13 '13 at 7:03
  • @durrgh Does the same error persist in safe mode? – Dave Oct 14 '13 at 7:22
2

check to see if you have msi command center installed, that was my issue. revo uninstall and it might fix your problem.

  • Thanks, but I don't appear to have that program installed. I used revo to get rid of a bunch of other nonessential programs which may have been causing the issues. – durrgh Oct 15 '13 at 0:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.