3

Recently I installed ubuntu 13.04 on my Lenovo T430.

The mute button on the laptop has an LED to indicate whether the sound is muted (LED on) or not (LED off). Ubuntu's software mute does not always match up with the state of the hardware mute.


The OS mute function does not change the state of the hardware mute. If the hardware mute is on, no sound. No matter what my settings in the OS are.

The hardware mute button does change the state of OS mute, but because the OS mute does not change the hardware state, they can be mismatched.

Is there any way to sync the two so the both reflect reality? Not sure if this is a driver or firmware problem. Perhaps it's just a feature that Ubuntu doesn't support.

2
  • Possible duplicate over on askubuntu: askubuntu.com/questions/125367/…
    – ernie
    Commented Sep 17, 2013 at 21:29
  • 1
    @ernie In that question the user's hardware button presses weren't being recognized at all. As I said in the question, the button press is recognized in ubuntu, but the state in the OS is out of sync.
    – user201262
    Commented Sep 17, 2013 at 21:30

2 Answers 2

2
+100

This problem is well known by ubuntu. There are different laptop-manufacturer affected. Also the Lenovo T530 is shown there. Not exactly your model, but the same productline.

There is a bug-report but it's not solved yet.

I would suggest you, to try a possible solution from the askubuntu-QA because it looks like, it will possible solve your problem:

  1. Start alsamixer in the terminal.

  2. Make sure you've selected the internal sound card (not the HDMI or external ones) by pressing F6.

  3. Try to locate a setting for LEDs, presented between the sliders. In my case it lists a Mute-LED Mode. Use the to move to the right in case you have more sliders than fit on the screen.

  4. Move to the "slider" and adjust it using the and keys in order to find a Follow Master option (or alike). Also try to toggle the LED state manually by flipping the setting On/Off.

  5. Now move to the Master slider and press M to mute/unmute. The LED should toggle with it.

  6. Try to use the hotkeys to mute/unmute. The LED should toggle with it again.

enter image description here

1
  • +1 for finding the bug report, I hadn't seen that. Unfortunately, my sound card does not have a Mute-LED option, similar to the posts in comments. But alas, a bug is a bug, I'll just have to wait on it being fixed.
    – user201262
    Commented Oct 11, 2013 at 17:39
0

Installing indicator-sound solved the problem for me.

1
  • 1
    Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places.
    – DavidPostill
    Commented Apr 5, 2021 at 10:23

You must log in to answer this question.