0

I have a minimal CentOS 6.4 running off a VM through VirtualBox in Bridged mode. Fedora 19 is the host. I am completely unable to use yum update. Whenever I try, I get this error:

Error: Cannot find a valid baseurl for repo: extras

I tried googling extensively for an answer, but none of the suggestions (like try yum clean all, use google DNS, or uncomment #base= line in /etc/yum.repos.d/ files) are making any difference.

Please help me resolve this headache.

0

To rule out a problem with the extras repositories you can do

yum update --disablerepo=extras

This will only disable extras for a single instance of yum.

If you want to make this permanent you could add

enabled=0

to the [extras] section of /etc/yum.repos.d/CentOS-Base.repo. When I do this I place the enabled=0 after the gpgcheck=1 line of the repos section I wish to disable. In this case enabling it per instance is the opposite of the first option above, e.g.

yum update --enablerepo=extras

These instructions are assuming your internet connection is active and your CentOS 6.4 install has a valid IP address (displayed using ifconfig).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.