One of my end-users is having an issue when they open an MDB (Microsoft Access) file over the network. This user only uses this access database once per month, and it worked fine last month. This time, when we go to open it, it gave an External Content error, asking you to 'Enable' or 'Disable' the external content. Once you select enable, instead of bringing up the full database program (Like it does for everyone else) it brings up a 'Select Table' menu where you can pick and choose what looks like individual parts of the database.

So far I have changed Access and Excel to both allow External Data, as recommended by this article: http://office.microsoft.com/en-us/excel-help/block-or-unblock-external-content-in-office-documents-HA010065176.aspx

I have tried restarting the computer, doing windows / office updates, and looking through a few technet articles. Googling this issue doesn't come up with a whole lot of my specific issue, and all of our other users (Microsoft Office 2007 and 2010) are able to open this just fine.

This specific end user is using Windows XP running Microsoft Office 2007. Does anyone have any ideas on how to make it so when we go to open the file, it opens the database normally?

Let me know if you need any additional information. Thanks for looking into this!

EDIT 1: Based on Jeong Kim's suggestion, I verified that all network drives were accessible. We recently added a mapped drive to the system in question, but did not alterany of the others

SOLUTION: After looking into the mapped drives issue further, it appeared there were two drives mapped to the same place with different drive letters. Once I removed the extra one, we were able to open the file no problem.



The External Content error makes me think that the database has tables linked to another database stored in a network location.

On the computer you're having problems, try checking that all the network drives are accessible and mapped with the same drive letter as on the computers where the problem is not happening.

The database might be trying to look for external content stored at, say, N:\Some\folder\file.mdb, and cant find it.

| improve this answer | |
  • This could be part of the problem. Do you know of a way to look at what all a database is linked to? Thank you for the quick reply. – Callen L Sep 18 '13 at 14:20
  • There were two mapped drives going to the same place, once I removed the extra, we were able to open it successfully. Not sure of the rhyme or reason, but it's working. Thanks for the help! – Callen L Sep 18 '13 at 14:55
  • Schweet! (only just saw this, so did not see your first comment). Glad it's solved! – JKim Sep 18 '13 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.