1

Recently reinstalled windows and have AHCI enabled (perhaps it has something to do with AHCI mode). Basically, I have the option now to eject my hard drives in the "Safely remove hardware and eject media" facility at the bottom right of the tray bar. Except that, I would not want to eject my operating system hard drive, and probably don't really want to eject my data hard drives at any time either. Is there any way to stop windows from giving me this option? I don't want it.

  • 1
    There may be an option in your bios to disable hotswapping. If it's there you can disable this feature and stop it from coming up inside windows. – Richard Powell Sep 18 '13 at 16:00
  • 1
    Marking a dupe of your own question! High-Five and thank you! (doesn't happen very often). :) – Ƭᴇcʜιᴇ007 Sep 18 '13 at 16:11
  • Yeah I tried to delete it but I couldn't and I knew it was most likely going to be flagged so I might as well do it myself! :P – Jonathan Sep 18 '13 at 16:15
2

Since you didn't provide any specifics I'm going to hazard a guess:

You plugged your SATA drive into a port on the motherboard that's ear-marked for eSATA.

In turn the BIOS reports that is a removable device port, and Windows offers you the eject.

Try a different SATA port.

Otherwise, ensure you chipset drivers are fully-up-to-date and check your BIOS for options to flag those ports differently (this option is rare at best).

| improve this answer | |
  • Thanks, I know that they're not in eSATA ports though - had double checked in my motherboard manual, besides that - two of the ports I'm using hasn't changed since switching to AHCI and they both are capable of being ejected now as well. – Jonathan Sep 18 '13 at 16:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.