So from one moment to the other, in Windows 7, i wasn't able to click certain elements of the UI. I could click icons in the taskbar but not on the desktop (just no reaction), then I could click icons on the desktop, but not on an active window (close window for example).

'Stupid windows' I thought, booted into Linux Mint, pretty much the same problem. I can use the browser, but when there another window (for example one to select a file to upload), that window doesn't react to click.

Right now I'm in a Firefox window on Linux Mint, I can click the tabs and menu items (File, edit ...) but can't close the window with the X icon.

It's not my mouse, both right- and leftclick work flawlessly. It's also not some stuck key on the keyboard, I disconnected it, to no avail.

I also tried around with Tab and I could use those windows as always.

What could this be?

EDIT: I begin to make some sense out of this: the mouse clicks sometimes seem to react to the window below the active window. For example, I have the start menu open and get the 'link' hand that you get when you hover over a link in your browser, because below the start menu there's a link in my browser. The PC doesn't seem to properly recognize which window is the active one, at least sometimes.

EDIT: I before stated that moving the 'focus' around with the tab key works good, but after further trying it doesnt.

Still, it is beyond my understanding how this could effect two entirely seperated operating systems.

  • Have you tried interacting with the UI using the keyboard instead to see if you get the same behavior? For example, when you open the File Upload dialog box, can you alt-tab to it and then tab around/use the directional keys to interact with it instead of the mouse? – vasken Sep 18 '13 at 18:34
  • Have you ruled out virus or malware? – Doktoro Reichard Sep 18 '13 at 18:35
  • 1
    I guess so, that malware would have to have infected both my OSes. – asco Sep 18 '13 at 18:37
  • 1
    It isn't impossible for malware to infect both systems. – Doktoro Reichard Sep 18 '13 at 18:38
  • @DoktoroReichard for it to have infected both systems and affect something as low level as the mouse? That probably is impossible. – terdon Sep 18 '13 at 20:30

I had almost the same problem last week! I found it was the touchpad - also affecting any mouse connected.

What bugged me most was the "only some parts of the UI" was clickable. And only sometimes and across OS'es.

Therefore I found that it was a hardware failure in the touchpad, making it randomly send "the left key is being hold down" action to the OS. This makes everything and sometimes only parts of the GUI un-clickable. This also messed up any other mouse I connected to the computer, since the signal was still randomly sent.

Are you on a laptop? Could your touchpad be broken too? If so, you could try disabling the broken touchpad through commandline:

xinput list

You will get an output that looks like this:

bolli@HAL:~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                         id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=12   [slave  keyboard (3)]

Now find the id of your touchpad or whatever could cause this, and disable it with this command:

xinput set-prop 11 "Device Enabled" 0

In this case 11 is my Touchpad id found in the list above. 0 means disable - you can change that to 1 in the same command to enable it again.

It's just a wild guess, might be worth a try.

  • Thanks for your answer. My pc is not a laptop. I fixed the problem by kicking it, I'm not joking, I kicked the case out of anger, the pc went out. Started it the next day and never witnessed the problem after ... – asco Oct 17 '13 at 8:27
  • haha great way to solve the problem. That would have been my next suggestion. Cheers :) – Bolli Oct 17 '13 at 13:18

I was searching for solution to very similar problem and as Bolli wrote something about mouse coliding with touchpad, I realised that I have two mice connected to my PC. Disconnecting one immediately solved my problem. I hope it will help to someone. (My problem was on openSUSE 13.1, when occasionally only a part of UI became clickable. Right-clicking in active part enabled everything and left-clicking disabled clickability of everything but the part of window I just clicked in.)

protected by Community Jan 23 '15 at 17:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.