After upgrading Windows Installer version from 3.0 to 3.1 on Windows XP Pro SP2, and then installing SP3 for XP (which includes Windows Installer 4.5) I started having these errors. When I log on to Windows, autostart objects start to load etc. and after some time I get a "Windows Installer" dialog box "preparing to install" although I have not started any program installation process.

When it's done "preparing to install" a new dialog box says that the "network resource" is unavailable. Network resource?... I have no clue what it's talking about. I just want to get rid of this shit! So much so that I have manually deleted the program files for the concerned programs without using the uninstaller.

Why not use the uninstaller? Because, I could not just click Cancel on the Windows Installer dialog box to get out of it. It would come back up again! And again! And again! If I clicked OK, it would say "network resource" unavailable. If I clicked Cancel it would pop back again! So it would get stuck in a loop like that. I had to kill the process to get out of it!

Once I gout out of the "network resource unavailable" dialog box, another "preparing to install" dialog box would appear, this time for another program. The first dialog box appeared for something called "Logitech Communication Manager". The second dialog box was concerned with Microsoft Office 2007.


The search path C:\MSOCache mentioned above is now gone. I have deleted it. It was empty anyway, had only two {1111-2222-3333-4444, etc.} type of folders and they too were empty.


Here, if I click OK, it supposedly tries to connect to some "network resource". It fails to find it and goes back to previous dialog box. What is it expecting to find, and where is it looking?


The name of the package it's looking for is EnterpriseWW.msi right now, but other MSI files have appeared here also, before I started destroying the installed program by deleting its files.

If I tried to use any of the uninstallers, for any of the programs, it would actually enter the "preparing to install" instead of "preparing to uninstall". In other words, it would start the installer program instead of the uninstaller. And I was back in the loop...

Now, I got rid of everything Logitech, and I no longer have the Logitech problem. The only Logitech program I really had installed really was "SetPoint" - the Logitech keyboard and mouse configuration software. I think the version was 4.0, FWIW. I did try getting the same version, that's why I know the version number, to try to install it over the old stuff but it didn't work.

I have completely deleted Logitech folder from C:\Program. I also deleted all Logitech related registry keys and Logitech folder from Start menu. But I still have Microsoft Office trying to "prepare for install". Even after deleting all folders and files in C:\Program\Microsoft Office. I even deleted MSI files in C:\Windows\Installer that had "Microsoft Office*" as Subject. It still manages to open the Office 2007 installer window. Where is it getting that from?...

What else do I have to delete? How do I get rid of this stupid error?

Other things I tried was following this Microsoft KB article on how to manually remove Office 2007 suite. But I couldn't follow through, because while in C:\Windows\Installer and I right-clicked on an MSI file and then clicked Uninstall to install them individually one by one (like it said in Microsoft KB article) it would still bring up the God damn "network resource unavailable" error.

Another thing I tried was using the Windows Installer CleanUp Utility. Microsoft no longer hosts this program on their website, so I had to download it from MajorGeeks.com. Now that I think about it, I think these errors started right after I upgraded from Windows Installer 3.0 to 3.1. Because this utility stopped working later on, probably when Windows Installer got upgraded to 4.5 by installing SP3. But while this utility was working, I was able to see a list of programs which I suspect are the ones using MSI/Windows Installer deployment. Among them was Office 2007 and if I'm not mistaken there were also some Logitech entries in there. I wasn't sure if I should use this utility so I didn't. In pure desperation I then installed SP3, hoping that upgrading the Windows Installer components would get rid of any of these glitches.

Well of course, I also tried the different "Microsoft Fix it" programs. More specifically, I downloaded the offline portable installer for Microsoft Fix it and then tried running the fix called "having problem installing or uninstalling software" or whatever they call it... it didn't resolve my problem. I don't know the KB number right now, but this is supposed to be the "replacement" software for the old "Windows Installer CleanUp Utility" I mentioned above.

  • you cleaned the Office setup cache. Point to the Office DVD and see if this helps. – magicandre1981 Sep 19 '13 at 4:22
  • Have you validated the startup list to ensure that this is not being launched? You can use msconfig (Start->Run->msconfig) to check to see which applications are starting on boot and see if one of those is the culprit. – aolszowka Dec 7 '13 at 2:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.