I was having trouble trying to setup triple boot on my computer... (Take a look at this thread if you think it would help).
I ended up by having a GRUB menu that has Ubuntu entries and "Windows" entry, that calls an EasyBCD menu to choose between Windows 7 and XP.

Everything would be fine if, only if, GRUB was set up correctly.

I can't find why, but it throws me this when I try to open Ubuntu:

enter image description here

I've already tried to remove the menu.lst and do a grub-update, and a grub-install too.
I tried to create a symlink to /dev/sda1 at /dev/disk/by-uuid/<<uuid that is there>>, just like the other UUIDs that were there... But I couldn't find that symlink at that busybox that opened when it thrown me the error.

Any ideas?

This is the GRUB entry with problems:

title Ubuntu 9.04, kernel 2.6.28-15-generic
uuid b1ed36e5-4d84-4eb8-86ef-6f1135ffc238
kernel /boot/vmlinuz-2.6.28-15-generic root=UUID=b1ed36e5-4d84-4eb8-86ef-6f1135ffc238 ro quiet splash
initrd /boot/initrd.img-2.6.28-15-generic

And this my /dev/disk/by-uuid folder:

04DCBCFBDCBCE856 -> ../../sdb1 (NTFS backup disk)
4434E77734E769FE -> ../../sda4 (NTFS WinXP)
ACB09F0DB09EDCE0 -> ../../sda2 (NTFS Win7)
b5311be8-a853-4fdd-aed5-d65974b3c0c4 -> ../../sda5 (EXT4 home)
C04B-4D97 -> ../../sdc (FAT32 live-pendrive from which i'm running)
D28447F68447DB9B -> ../../sda6 (NTFS files partition)
e0e88f38-d815-423a-9d5e-64b9c74a8b92 -> ../../sda7 (swap)

  • can you post the relevant entry of your /boot/grub/menu.lst? in particular it will help to see the kernel line. (maybe just post the output of this command: grep kernel /boot/grub/menu.lst) Nov 3, 2009 at 0:46
  • or if you can't get to it, write down what you can see on the kernel line from within Grub at boot-time. it's likely the root= parameter is broken. Nov 3, 2009 at 2:42
  • Added what you asked and the by-uuid. xD Nov 4, 2009 at 1:43

2 Answers 2


I'm really sorry, I totally lost track of this question. Did you ever get it worked out?

According to the /dev/disk/by-uuid listing, there isn't a UUID associated with /dev/sda1. Are you sure it's still a valid root partition?

  • You should be able to check with the command sudo tune2fs -l /dev/sda1. If that works,
  • try running fsck on it (start with sudo fsck -n /dev/sda1 to see if it reports any errors), and if that works
  • try mounting the filesystem (sudo mount /dev/sda1 /mnt or similar).

If those three tests work, maybe the problem is that something accidentally unset the filesystem's UUID. You can try resetting the UUID to its old value with this:

sudo tune2fs -U b1ed36e5-4d84-4eb8-86ef-6f1135ffc238 /dev/sda1

If one of the filesystem tests fails, you may have another problem on your hands, but there are too many possibilities to go into without further info.


Only need reinstall grub2 and uninstall grub and these kernels which aren't refresh. This is good for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .