1

I have a Lenovo T60p laptop, where the Alt and AltGr keys have stopped working. I use a Danish keyboard layout, where these keys are essential to produce many characters.

I have done the following:

  • Re-installed Windows 7
  • Installed a new (used) keyboard.

Alt is still not working (But CTRL+ALT+DELETE does work).

I think it is unlikely that both the keyboards I tried have the same defect. Do I need a driver for the Thinkpad ? Some other software issue that could cause this ?

  • 1
    If CTRL-ALT-DEL works, then the ALT key works. What makes you think it's not working? If you turn on Windows' On-screen keyboard, does it reflect that your pushing the Alt key when you do? If you boot from a different OS (say a Linux LiveCD) does Alt work as expected? – Ƭᴇcʜιᴇ007 Sep 19 '13 at 16:46
  • The characters that need an Alt combination to type is not working. Alt+2 should get me @, etc. I have, of course, checked that the correct keyboard layout is selected. – driis Sep 19 '13 at 16:50
  • ok I'm not sure how the Danish keyboards are laid out, but on a standard English keyboard to get the @ (over the 2) you use Shift-2 not Alt-2. – Ƭᴇcʜιᴇ007 Sep 19 '13 at 16:52
  • By Windows Keyboard Layouts, the Commercial At (@) character should be produced using AltGr+2 – JosefZ Jan 2 '18 at 22:15
2

Even it is very old question - I will answer.

Because It bothers me a lot of time with my Lenovo 700 17-ISK.

The 2 Alt keys - didn't work on my NEW Lenovo computer.

The solution is in Intel Graphics Settings software.

How to solve :

  1. Open Intel Graphics Settings in your computer.
  2. Go to Options And Support
  3. Go to Hot Key Manager
  4. Disable the option "Manage Hot Keys".
  5. Click on Apply and close the software.

Now the Alt keys - return to work very good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.