I am running Windows 7, 32-bit java up to date. On Chrome, Firefox and IE (also up to date) whenever I load lowes.com the scroll over menus (shop & learn) will work while the page is loading. At some point fairly quickly in the process of loading, they quit working. The mouse still changes cursor when hovering over these menus but the menu doesn't open. Also on the same site, pushing the button to enter a zip code doesn't work. I've noticed similar things on other sites, but this one is the one that's driven me over the edge.

The thing that's killing me is that the sites work as expected in all three browsers when I'm in private mode. I tried disabling all the add-ons in all three browsers and the site still doesn't work.

To summarize, whatever is stopping the javascript from working:

  1. Interferes with three different browsers (Chrome, FF and IE)
  2. Interferes after the element loads
  3. Does not interfere when using private browsing
  4. Interferes even with all extensions disabled in all browsers
  5. Is not a simple disabled javascript setting in each browser

Also, I use a download manager, but I tried killing it when all the extensions were disabled and got the same behavior.

Any thoughts on something else I can try?


It's possible javascript later in the page is corrupting the menus. Try blocking all the adds and see if the menus work.

  • I did this and the menus and buttons still don't work. – William Everett Sep 20 '13 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.