0

my setup
host: win 7
guest : opensuse [10.0.2.15]
Ports forwarded 80, 22 from 127.0.0.1 to 10.0.2.15
Connection to VM using winscp with user@127.0.0.1:22 using public key authentication is working. I can access Apache as well by going to 127.0.0.1 on host machine.

I can't access mysql by using ssh tunnel. I am using heidisql. I have another remote machine which I am accessing via ssh tunnel and it is working fine with same configuration on that server.

I always get

"SQl Error(2003) in statement #0: Can't connect to MySQL server on 'localhost' (10061)"

What am I doing wrong?

  • update: if I use putty to first open tunnel and forward port 3308 to 127.0.0.1:3306 and then use heidisql to connect via tcp/ip with port 3308, I am able to connect with same credentials. I guess it may be heidisql issue. – codescope Sep 20 '13 at 4:08
1

I was having the same problem. I solve it by increasing "plink.exe timeout" setting in ssh tunnel tab.

  • This helped me with the same problem with MySQL Workbench. Doubling all the TIMEOUT values in the Preferences -> SSH resolved the connection problem. – RusI Nov 22 '18 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.