0

I'm not very experienxed with Debian/Ubuntu. I follow this guide:
https://mariadb.com/kb/en/installing-mariadb-deb-files/

And this one for adding the required repositories (I don't install MariaDB!!!): https://downloads.mariadb.org/mariadb/repositories/ Ubuntu -> 12.04 -> Mirror near to you

My actual steps:
1. fresh install of Ubuntu 12.03.3
2. apt-get update && apt-get dist-upgrade
3. apt-get install openssh-server # remote access for me
4. vim /etc/apt/sources.list.d/mariadb.list
5. paste into file

# MariaDB 5.5 repository list - created 2013-09-20 12:39 UTC
# http://mariadb.org/mariadb/repositories/
deb http://mirror2.hs-     esslingen.de/mariadb/repo/5.5/ubuntu precise main
deb-src http://mirror2.hs-esslingen.de/mariadb/repo/5.5/ubuntu precise main  
  1. apt-get update
  2. apt-get install mariadb-galera-server galera

This fails:

....
Selecting previously unselected package galera.
Unpacking galera (from .../galera_23.2.6-precise_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
Setting up mysql-common (5.5.33+maria-1~precise) ...
Setting up mariadb-common (5.5.33+maria-1~precise) ...
(Reading database ... 79533 files and directories currently installed.)
Unpacking mariadb-galera-server-5.5 (from .../mariadb-galera-server-5.5_5.5.32+maria-1~precise_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/mariadb-galera-server-5.5_5.5.32+maria-1~precise_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/mysql/plugin/dialog.so', which is also in package libmariadbclient18 5.5.33+maria-1~precise
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package libhtml-template-perl.
Unpacking libhtml-template-perl (from .../libhtml-template-perl_2.10-1_all.deb) ...
Selecting previously unselected package mariadb-galera-server.
Unpacking mariadb-galera-server (from .../mariadb-galera-server_5.5.32+maria-1~precise_all.deb) ...
Processing triggers for ureadahead ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/mariadb-galera-server-5.5_5.5.32+maria-1~precise_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

What is going wrong? I tried it already with pinning, but I doesn't help either. Is it possible, the repositories of MariaDB are not in clean state? Merely saying mariadb-galera-server is in conflict with it very own dependency libmariadbclient18

Thank you

1

There are currently some known installation issues I've also encountered yesterday. The MariaDB guys have "created a page for those who ran into the packaging bugs present in 5.5.33":

MariaDB 5.5.33 Debian and Ubuntu Installation Issues

You can try changing your sources.list configuration to

deb http://ftp.osuosl.org/pub/mariadb/mariadb-5.5.32/repo/ubuntu precise main

and run a sudo apt-get update after that. Then simply install the older version until they have fixed everything:

sudo apt-get install mariadb-galera-server
  • Thank you! Looks like we have to wait for a final fix with the release from galera 5.5.33. – Peter Weber Sep 23 '13 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.