Here is a description of my setup:

I have a Brother DCP-7020 USB laser printer hooked up to a desktop computer running Ubuntu 12.04 LTS (Xubuntu desktop, if it matters). In my room is a laptop with Windows 7. The Ubuntu computer has SAMBA configured with the same workgroup (if I got the term right) as the W7 computer. In the printer option on the Ubuntu computer, the printer's shared setting is checked and in the CUPS server setting "publish printers attached to this machine" (may have misworded that, you should get the general idea) is checked.

Here is my problem:

Certain applications won't print from the Win7 machine. Word 2010, Excel 2010, and Windows Live Photo Gallery work. Notepad++, Programmer's Notepad, WordPad, and Foxit Reader do not work. I have had no trouble printing anything from the Ubuntu machine. Printing a test page from the Win7 machine also works, and the computer has no trouble recognizing and connecting to the printer.

I have installed the correct Linux drivers from the Brother website (brother2 drivers).

In Foxit Reader, for example, when I print, "\UBUNTU\FamilyPrinter" shows up in the name field and the Status says Ready. However, when I print the printer does nothing. It doesn't even show up in the job queue on the Ubuntu machine.

I tried printing from a Linux Mint virtual machine I have set up in VirtualBox on the Win7 machine (Bridged Adapter, correct SAMBA settings, etc.) and that worked just fine from the default PDF viewer.

Why do some applications on Win7 work, but others don't? How can I fix this?

  • Partial guess here (I'm doing printing the other way 'round), but here's some things to try checking: Check to see if you have one set to a PS driver, and the other to a PCL driver. Some office suites may try converting the contents to a PDF before sending - so check to see if office is doing any conversions causing some double-conversion mistake. Lastly, maybe look at the CUPS log file to see if there's anything blatant in there (e.g. "Error doing XYZ" "Corrupt XYZ"). Also, if you can, check to see if some settings in Office may be preventing jobs from being sent for any reason. – user870018 Sep 20 '13 at 15:38
  • Office is one of the programs that WORKs. Sorry if I didn't make that clearer. – Mark D. Sep 20 '13 at 16:10
  • I'm also having this problem. I can print without any issues from my Linux server to the HP LJ4 connected to it, but from Windows 7, while the printer test page prints fine, I can't print from NoteTab or Notepad; the job just goes nowhere and vanishes. I can print from Outlook fine. Did you ever find a solution to this? – boot13 Jul 9 '15 at 13:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.