I installed VMWare workstation on my laptop, which has Windows 8 running on it. I got VMWare installed, after which I tried to install Red hat Linux as a guest OS.

But I get an error stating "not enough physical memory available to start this VM."

I tried allocating all more resources to get Linux installed and overcome the above error:


but still get the same error.

  • 3
    How much memory does your laptop have? Do you have other processes running on the host (Windows 8) that are taking up a lot of memory? Remember that Windows requires memory too, so even if your laptop has 2 GB of RAM, you won't be able to allocate all of that (maybe not even most of it) to a guest OS. – John Bensin Sep 20 '13 at 18:44
  • 2gig ram it seems. – Lorenzo Von Matterhorn Sep 20 '13 at 18:46
  • 1
    My laptop has 4GB RAM out of which i alloted 2GB to VMware – user256091 Sep 20 '13 at 18:58
  • You need to try to allocate less RAM to the VM, not more. Trying to allocate more RAM makes it more likely that the allocation will fail. – David Schwartz Sep 20 '13 at 19:10
  • 1
    @user256091 What other processes do you have running? Can you open the Task Manager (press Ctrl+Shift+Esc), and in the performance tab, look at the graph of memory and tell us how much memory your system is currently using? – John Bensin Sep 20 '13 at 19:20

You probably need to run VMWare workstation as an administrator. Some Windows Updates have created this problem from time to time. Follow the first recommendation in this article: http://www.petri.com/fixing-enough-physical-memory-available-errors-vmware-workstation.htm

  • 1
    Welcome to Super User! Please include the relevant information from the linked page in your post. If the link is ever broken, your answer will no longer be as useful. – Excellll Nov 13 '14 at 21:09
  • I'm having the same problem with VMWare Player 4.0.6 on Win8.1/64 with 10GB of RAM, no visible application running, when trying to launch a 1GB Linux VM. Running as administrator helped, uninstalling KB2995388 didn't. I've not tried messing with config.ini. – Thomas S. Oct 1 '15 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.