So I'm trying to install Skype on my office computer which has CentOS6.4 and where I have no root access. http://www.skype.com/en/download-skype/skype-for-computer/ only offers binaries for Ubuntu, Debian, Fedora and OpenSUSE. I tried the dynamic one, but it complains:

skype: error while loading shared libraries: libasound.so.2: cannot open shared object file: No such file or directory

The README recommends copying the skype binary to /usr/bin and installing sounds/, lang/ and avatars/ into the /usr/share/skype directory. Obviously I cannot do this, because I don't have root access.

Any other online CentOS installation guide always assumes root access.

I wonder: can it be done at all?

  • If you have wine installed, you could try to use the windows version of skype in wine. – Tim Sep 25 '13 at 10:02

You don't have required 32-bit libraries. If you have x86_64 arch CentOS installed you'll probably have to install some dependencies (i686 packages) for Skype using YUM.

Try searching for a package that contains that library libasound.so.2.

Example: yum whatprovides libasound.so.2


alsa-lib-1.0.22-3.el6.i686 : The Advanced Linux Sound Architecture (ALSA)
                           : library
Repo        : installed
Matched from:
Other       : Provides-match: libasound.so.2

Use that information to search for dependencies and then install.

Example: sudo yum install alsa-lib.i686

There'll be a few i686 dependencies for skype so you'll have to run Skype and resolve dependencies a few times before you get it to work. Good luck!

PS. Without root access, I don't think you have any chance

| improve this answer | |
  • This seems like the correct answer (ldd confirms the lack of packages), accepted it and will upvote as soon as I have the reputation to do so :-). Also thanks for the PS, I think I will ask the sysadmins instead. – niefpaarschoenen Sep 25 '13 at 11:47

You only have to unpack the .tar.bz2 into a folder somewhere in your home directory and run the skype executable.

If you have problems running it, try a different version (e.g. you could have another version than the one needed).

| improve this answer | |
  • wont it still need a chmod +x ? – Lorenzo Von Matterhorn Sep 25 '13 at 9:13
  • 2
    @LorenzoVonMatterhorn No. Since .tar.bz2 files preserve file permissions it is already executable immediately after unpacking. – Tim Sep 25 '13 at 9:20
  • good point. upvoting. – Lorenzo Von Matterhorn Sep 25 '13 at 9:21
  • That's exactly what I did to get the above mentioned error message. Although it didn't make sense to me, I tried all the other versions as well, to no avail. – niefpaarschoenen Sep 25 '13 at 9:27
  • @niefpaarschoenen Sorry I missed this. Maybe you can try to download alsa-lib-1.0.22-3.el6.i686 (which Ashtray suggested) using your browser. Extract it (e.g. by opening it and the CONTENTS.cpio in it with mc) and copy the libraries in question to your local skype directory. Maybe it works, but I think your chances are indeed very bad without root access. – Tim Sep 25 '13 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.