0

I am trying to setup my ISP router and my TPLink TL-WR741N router to share the same subnet.

The ISP router is connected to a fiber optic cable (Internet connection), and I'm running an Ethernet cable from the ISP router LAN 1 port to the TP-Link router's LAN 1 port. I have disabled DHCP on the TP-Link, and set its IP to 192.168.1.2 since the ISP one is 192.168.1.1.

When I connect to the TP-Link router with WiFi, I can ping other computers which are connected to the ISP router and the other way around. I can also ping all IPs. However, I can't open any web pages. I found out that the DNS is not working on the TP-Link router. That can be fixed by manually adding DNS servers in the adapter properties on Windows.

That's more like a quick fix however. Is there any other way I can fix this on router level?

EDIT:

I forgot to mention that there are two places where I can add the DNS servers on the TP-Link router:

  • On the DHCP settings, which are disabled
  • On WAN port settings, which is also not used
3
  • I forgot to mention that there are 2 places where I can add the DNS servers. On the DHCP settings, which are disabled. And on WAN port settings which again is not used. (Updated the Post) And yes, I tried adding that as well. Same result.
    – Dzoni
    Sep 25, 2013 at 11:21
  • 1
    If your clients get IP configuration settings via DHCP from one of your routers then configure your router, so that it would hand out DNS server addresses in DHCP messages.
    – Ashtray
    Sep 25, 2013 at 11:34
  • They would normally get their DNS setting from a DHCP server. Is the "ISP router" a router or a modem? If it's a router and all of your LAN ports are bridged on both routers, the DHCP packets should travel over from the "ISP router" to any devices on the TPLink router.
    – hololeap
    Oct 5, 2013 at 23:34

1 Answer 1

0

After 2-3 restarts of both routers the TP-Link router started accepting the default DNS servers specified by the ISP (all in one) router. So I guess the issue is resolved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .