4

It seems since I connected a third monitor the desktop icons can't be placed at the bottom row.

Here's a screenshot:

enter image description here

Any idea how to fix this? Thanks.

1
  • Since you'ce called (Debras) correct answer to this question, 'not useful', you may be hapier with simply disabling this feature altogether. Right click on the desktop and deselect 'View->Align Icons to Grid'. This will let you put the icons exactly where you like. – krowe Jan 15 '17 at 16:46

12 Answers 12

6

This has to do with the icon vertical spacing. Whatever you have it set to, there isn't a full row remaining below (between what you see & the taskbar) so the bottom full row seems as if it has a row of space below it, when actually it's not enough space for another row.

So if you want to have the icons land lower, you have to adjust the vertical spacing for icons. I usually do this a pixel or two at a time.

In Windows 7, it's in the Display Properties as right-click on empty space on the desktop > Personalize > Window Color > Advanced Appearance Settings > Icon Spacing (Vertical). Just bump it up a pixel or two at a time, then re-auto-arrange the desktop etc. until you find a setting that arranges the rows so that the top is at the top & the bottom is close enough to the bottom to suit you.

I'm not sure if I'm being clear, but simplified: suppose the screen is 100 pixels high. If you set the icon spacing to 13 pixels, you'll fit 7 rows and have 9 pixels left at the bottom (out of the 13 needed for another row), so it might look very much like your posted image. But if you set the vertical spacing to 12 pixels, it will only have 4 left at the bottom, so will seem to be more of a "bottom row".

6
  • I actually tried that solution before, trouble is that icons they get too close together if I decrease the distance between them. – Andres Sep 26 '13 at 6:38
  • To complete the comment above, here is an image of how it looks if I apply that solution: s18.postimg.org/m2mtipdvb/44454.jpg – Andres Sep 26 '13 at 13:56
  • Try increasing the space instead, 1 or 2 pixels at a time. – Debra Sep 26 '13 at 16:44
  • no, that's even worse, i don't need to change the distance between icons, i just want to be able to place icons near the task bar. – Andres Sep 26 '13 at 20:22
  • Andres, when you have them aligned to the grid, you have to adjust the vertical spacing if you want them to land closer to the taskbar. Please go back to my example above about how they are arranged -- there is not enough room left below them now to put another full row in. The location of the rows is completely based on that icon vertical spacing setting, so this is the only way to fix it unless you want to turn off the auto-alignment & then place them closer manually. You won't notice a 1-2 pixel change, but it will cumulatively change where the bottom row lands. – Debra Sep 27 '13 at 4:38
0

I came across the same issue when I added a second monitor. Couldn't figure out what was causing it or how to resolve it for a while. Then I just chanced messing around with the screen resolution and I swapped the order of my monitors in the screen resolution dialog box. So my inital monitor is now set as screen/monitor no.2 whilst the monitor I added to my system is set as monitor no.1. Dont know how/why it worked but it did so Im happy enough with that. Maybe it is worth a shot for you too?

0

I have had to fix this a couple of times after adding a new monitor. It's most likely due to your monitor alignment being off. Your icons will only go as low as your highest monitor is set.

Right click -> screen resolution, and move the monitors so the bottoms line up. That should fix all your icons.

0

Control Panel -> Display -> Switch from Medium to Smaller - 100% (you can still adjust icon size by holding Control and using mouse scroll wheel). Worked for me.

6
  • Are you sure this is a solution to the problem described in the question? – fixer1234 Feb 12 '15 at 23:50
  • Yes, I had the same problem, and this fixed it. That's why it says "Worked for me". Have you tried this solution? – Zook Feb 13 '15 at 0:27
  • I don't have the problem. The solution just seems unrelated to the issue in the question. Just wanted to verify. – fixer1234 Feb 13 '15 at 0:28
  • Try doing the opposite of the solution and see if that causes the problem for you. For reference, my screen resolution is 1920 x 1080. – Zook Feb 13 '15 at 0:29
  • Good suggestion, but I use Linux so it isn't an issue in either direction. I suppose that could be considered another solution. :-) – fixer1234 Feb 13 '15 at 0:31
0

This is obviously a pretty old post but I just had an issue crop up where this happened to me. I figured out how to get stuff where I wanted, however, I'm not saying this will work for you or anyone else that experiences this problem.

One of my icons moved after I opened up a game and the resolution wasn't set properly (because of a new monitor) so you know some fullscreen games will put your other display out of whack till you fix the resolution? well it moved an icon when it did that. I tried moving it back but it just snapped back to where it got pushed to like an invisible magnet pushing away another magnet when you have them flipped to opposite sides.

FIX SOLUTION HERE-Anyway here's how I found out how to fix, at the very least, my issue. I found out that if I have an icon in the space ABOVE where I want to put another icon it WILL go there, however, if there isn't an icon above the spot I want to put it then it just snaps back to a different spot and won't go there. Weird right? Hope this helps you or anyone else that finds this thread and has this issue.

0

I know this is an old post, but I found A solution... Now, keep in mind, I still have no idea what the hell the root of the problem is, and after finding a few ways to fix the issue, none really satisfied my... practically OCD type requirements of positioning :D

There are a few solutions I found worked for me.

  1. Right click your background > Screen Resolution > click and hold one of the displays present, and move it to the other side of the other screen, i.e.: switch around their positions. It works, fixes the grid issue completely, but I prefer my main screen be on my right and secondary on my left... I don't know why, but I'm clinging to that system :)

  2. Place an icon above the spot on the bottom where you want to move an icon, and once that icon is there, you can drag the icon you want right to the bottom and it will stay. You can move the icon then, but the icon on the bottom, I found, will always eventually move up a row.

  3. The best solution I found by messing around with positioning, when you right click your screen and go into the "Screen Resolution" menu, or Appearance and Personalization if you want to find it through the Control Panel, you can grab your main screen (or whichever screen is the one with the issue) and move it up a little. Now, it wont let you do a little, it will snap to predefined points, but you can pull the screen to the side, keeping it on the same level as the other, then it won't be bound by those predefined spots, move it up JUST A LITTLE BIT... seriously, a pixel or 2; then let go of the mouse, and it will snap back to the side of the other screen, but it will be positioned higher than the other, but only by so little you won't notice it, but your icon issue gets fixed.

Again, I don't know the root of the problem, if I did, that would be a lot better, because I could find an actual fix, but I'm just glad my damn icons are back in place. I hope you find it helpful too! :)

0

All correct. placing an icon OVER the spot I wanted another icon in, allowed me to place it there. Some text was cut off since there wasn't really enough room, but I can live with it. Now to get them close to the right side. I know I have located it b4, but where is the reg entry that controls the horiz & vert height of the desktop icons?

0

This is a bug i found today. To move a icon in the bottom row, place it anywhere before. Place any other icon directly above it. Select both icons, and drag both of them by using the upper(!) icon down to the row before the bottom. So your desired icon will be placed in the bottom row.

1
  • Welcome. This sounds like an answer; why do you describe it as a bug? – I say Reinstate Monica Jun 29 '19 at 11:30
-1

If you uncheck Align to grid from Desktop properties, you can drag your icons wherever you want.

-1

right click on desktop and go to view.Then uncheck allign icons to the grid and you can place them everywhere you want.

-1

It is very easy to solve. At first I too faced this But I cleared this problem with one right click and one left click. First Right click on your desktop and go to view option and click on the "Align icons to Grid". You can see your icons as you wanted.

-1

Here's what worked on my Win 7 machine: Right clicked on desktop. then clicked view and deselected, "Align icons to grid." Worked perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.