90

Since the last update it has been impossible to hide the most visited sites. I don't know if it's some temporary sick joke by the chrome team but I need to remove it.

I have tried changing my home to something other website, this works for when you first launch chrome but not for opening news tabs.

enter image description here

5
  • 2
    All features and bugs of Chrome that you don't agree with are temporary sick jokes by the Chrome team.
    – zylstra
    Nov 5, 2014 at 22:06
  • @Nemo: Can you clarify how the proposed duplicate relates to hiding most visited sites?
    – fixer1234
    May 3, 2015 at 20:46
  • @fixer1234 the only way to hide "most visited sites" in recent versions of Chrom(e|ium) is to use an extension which makes the initial/new tab entirely blank. All the answers posted here say the same, except the accepted answer which is now wrong.
    – Nemo
    May 3, 2015 at 21:08
  • @Nemo: Thanks. Not being a Chome user, that wasn't obvious from the answers. Sometimes duplicates are virtually identical questions, sometimes the question is different but the answers also solve what was asked. In the latter case, the people who vote on closure as a duplicate may not be aware of how you think it applies. In those cases, it better to include an explanation in the comment so people know what to look for. BTW, thanks for finding all of these duplicates.
    – fixer1234
    May 3, 2015 at 21:21
  • @fixer1234 you are right, I just forgot to go back to the questions and add an explanation after using the "flag" link.
    – Nemo
    May 3, 2015 at 21:26

7 Answers 7

20

Currently, the only simple solution is to use an extension.

Before Chrome version 33, released 20th February 2014, this solution was possible:

  • Enter chrome://flags/ into the address bar
  • Search for "Enable Instant Extended API"
  • Set it to Disabled
  • Restart Chrome

You may have to click on the 'x' on the right of each cached thumbnail to get rid of it.

At the time of writing, September 2013 this worked.

5
  • 22
    This no longer works in Chrome 33+. See my answer
    – niutech
    Dec 17, 2013 at 11:24
  • 1
    Not necessary and apparently inneffective. Answer added later works fine without chrome:// complexity.
    – jerclarke
    Feb 17, 2014 at 15:09
  • If you're launching chromedriver chrome_options.add_argument("--disable-instant-extended-api") works for me (tested at Version 59.0.3071.86).
    – Cynic
    Jun 9, 2017 at 0:28
  • Under chrome://flags there is an option "Capture page thumbnail on navigating away" which is relevant to disable. This is with Chrome version 63.
    – Ioannis
    Jan 3, 2018 at 2:26
  • type chrome://flags then disable "Top Sites from Site Engagement"
    – Amir
    Jul 31, 2018 at 9:57
38

There's an extension called Empty New Tab Page. Does exactly what it says on the tin.

8
  • Works great with Chrome 35.0.1916.114.
    – dvs
    Jun 6, 2014 at 13:00
  • 1
    Or New Tab Redirect Extension, and redirect every new tab to "google.com" itself. Jul 11, 2014 at 17:10
  • 3
    What I wonder is - after installing this extension does Chrome still download rel site thumbnails in background - or not? Oct 15, 2014 at 18:01
  • After installing extension, I also needed to go to Settings, and set On startup to go to Open the New Tab page.
    – robocat
    May 26, 2015 at 22:41
  • 2
    But this extension also removes my theme image at the new tab page. Apr 26, 2018 at 1:50
17

To remove any of the 8 most visited sites, hover your mouse cursor over the 'thumbnail' until a X appears at the top right hand corner. Click that. However your next most visited site will replace it.

5
  • This worked perfectly and is clearly what Google intends as of Feb 2014. Other answers seem to be from a time before this feature was available. After deleting 6 it seems Google wasn't tracking more than 10, so there are empty slots.
    – jerclarke
    Feb 17, 2014 at 15:07
  • My "x" was grey, so was difficult to see. This may be the case with your page icon also.
    – zylstra
    Nov 5, 2014 at 22:03
  • 1
    This does not remove the empty fields
    – ohcibi
    Jan 29, 2015 at 20:22
  • 6
    It also takes ages to do this for every website.
    – Nemo
    May 3, 2015 at 12:10
  • It also does not work reliably; some frequently visited websites just reappear (with the exact same URL) after being removed.
    – Tgr
    Oct 4, 2016 at 22:56
6

In Chrome version 80 there is a Customize button at the bottom right of the page:

Chrome Customize This Page

If you enable the Hide shortcuts then Chrome will not show any shortcuts.

2
  • 2
    This should be the accepted answer.
    – John
    Jul 6, 2020 at 17:19
  • This is the best answer for up-to-date versions of Chrome.
    – GTS Joe
    Dec 10, 2020 at 16:14
4

Try the extension listed on this blog: Source

Most how-tos only provide a solution to clear your most visited pages, not how to disable it. Both methods are easy: below:

How to Clear Google Chrome’s “Most Visited” Landing Page (until you start browsing again)

All you have to do is clear your browsing history. Click the Chrome icon on in the top-right corner of your browser, select “History”, then “Clear All Browsing Data.” Done.

How to Disable Google Chrome’s “Most Visited” Landing Page (until you want it back)

Grab the Chrome extension New Tab Redirect. Install it, enable it, and then select ”Options.” Now, you can either create a custom launch URL or you can simply enter “about:blank” as the URL to have new tabs/windows load a blank page.

2
  • 1
    Be sure you bring your information of the source, not just the link for your answer. Because the link might end up dead someday. Now it will be useful forever. Feb 18, 2014 at 3:41
  • I only wish I could give this more upvotes. By far my favorite solution to this problem!
    – Syndog
    Mar 7, 2016 at 21:40
3

Long-Click on the right side of the thumbnail (do not release the mouse button) until a little 'X' is shown in the top right corner of the thumbnail. Release the mouse button and click on the 'X'. Done.

1
  • 3
    I don't know what OS you are using, but in Ubuntu you don't long click - you just hover on the thumbnail for long enough and the X appears. It was hard to see the X on certain pages. Mar 6, 2014 at 12:14
1

Installing my Extension should to the trick :)

https://chrome.google.com/webstore/detail/hide-most-visited-pages-r/dhphmpoekpoecdbjeionimpiceigkeil

If you have any problems regarding this extension, hit me up on Twitter (@_emkae) :)

2

Not the answer you're looking for? Browse other questions tagged or ask your own question.