0

I have a VAIO laptop: VPCF13CGX, with a 64-bit Windows 7 Professional installed. It works fine, but sometimes it suddenly goes to sleep! I must press a key afterward to wake it up (of course), and after it wakes up my Wireless and USB devices do not work! Therefore, I have to restart it.

After searching Windows event logs (for Event ID 42; which is Sleep event) I found the following:

 The system is entering sleep.
 Sleep Reason: Button or Lid

But I neither pressed the power button nor closed the lid. Therefore, something is simulating this behavior on my system.

Any suggestions?

PS: (I have updated the graphics driver to the latest version, so this can't be the reason).

  • 1
    Are you sure your computer is not overheating? – Vlad Sep 26 '13 at 17:01
  • I don't do CPU intensive tasks when this happens. For example this happens when i am surfing the net or watching a movie, ... – gst Sep 26 '13 at 17:03
  • Well there could be a lot of issues. Go to Control Panel and Battery options, and check if there is any thing that sets the computer to sleep, and turn it off if it is. Otherwise, tell me if this happens when the computer is plugged into the wall. – Vlad Sep 26 '13 at 17:05
  • This happens when my laptop is plugged in. Also there is not a setting in the Power options to put my laptop in sleep mode. I am using the balanced mode to put my laptop into sleep after 30 minutes if there is no activity, but this happens when i am working with my laptop. – gst Sep 26 '13 at 17:10
  • Try unsetting that option, there is a possibility that there is a reason. It could also be power shortage. Try this: Remove the battery from the computer and plug the cord in. Tell me the results. – Vlad Sep 26 '13 at 17:14
2

It may be a magnetic band in your watch, Nike fuel device etc. The sensor will think that the computer lid is closed and will trigger the device to go into sleep mode.

0

I would recommend to try the following steps:

Step 1: Update the BIOS - It is possible that your BIOS cause these problems. So have a look at your BIOS-Version and if there is a newer version available, than update it.

Step 2: Check your BIOS-Settings - When there is an option in your BIOS-settings which contains "wake on lan", disable it.

Step 3: Use an Ubuntu Live CD to check if windows is the problem - Maybe it isn't windows which causes the "error". So you can use an Ubuntu Live CD and watch a movie or something to check, if windows causes the error or if the pc itself goes to sleep because of an overheating or something like that.

  • I still didn't tested the Linux, because it takes too long for the error to happen. – gst Oct 3 '13 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.