I am trying to install a linux distribution on my new laptop. It's an MSI GE40 which comes preinstalled with windows 8. It's a UEFI machine.

I have tried installing Ubuntu and Fedora with limited success. I've tried:

  • running it in UEFI,
  • UEFI with CSM mode, with secureboot enabled,
  • ... with secureboot disabeled,
  • ... with secureboot enabled but in user mode.

I have had no success with any of these methods.

With Ubuntu the grub loader shows up, but when I pick 'try ubuntu', or 'install ubuntu', it's just a blank screen(I've been using liveusb's btw). With Fedora, it'll show me the next screen on which it says 'binary authorised by vendor certificate' or 'Secure boot not enabled' and then stop doing anything. The closest thing to success I reached was switching to legacy mode to install Ubuntu, in which case I was able to get to the ubunutu installer but it wouldn't recognize windows 8 on my computer, so instead of continuing on I rebooted, and removed the USB pendrive to find my computer couldn't find windows 8. After a little dicking about I got it to find windows 8 again.

Any ideas on how I should go about trying to install a distro on my computer?

UPDATE:- So I ended up installing fedora using Legacy mode. To use both it and Windows at boot, I manually enter automatic repair so I can get to my UEFI settings and switch boot mode to UEFI to boot windows 8. I guess my question needs to be modified as to how do I get all of this to work in UEFI mode, so I can dual boot via selection through a bootloader, and not by repeatedly switching boot mode.

  • If you have secure boot disabled and are using a UEFI boot disk it should simply work. I am not sure what this question has to do with Windows 8 your problems are not caused by Windows – Ramhound Sep 26 '13 at 19:15
  • @Ramhound I wasn't implying there is a windows 8 problem, I was just asking for hekp – TryntaLearn Sep 26 '13 at 21:00

My recommendation is to try my rEFInd boot manager. You can try it risk-free as follows:

  1. Download the USB flash drive version of rEFInd from its downloads page.
  2. Prepare a USB flash drive with rEFInd.
  3. Mount the USB flash drive and edit the EFI/BOOT/refind.conf file on that medium. Locate the scanfor line, uncomment it, and add hdbios to the list of options.
  4. Boot from the USB flash drive. It should present options for Windows, probably one or more for Fedora (which probably won't work), and a grayscale generic option that should launch your BIOS-mode GRUB installation.

If rEFInd works in this way, then you can install it to your hard disk from Windows, as described in the rEFInd documentation. You'll need to alter the refind.conf file on the ESP just as described above. If you don't install any EFI filesystem drivers, the resulting disk-based installation will let you select between EFI-mode Windows and BIOS-mode GRUB/Linux, but it won't show the Fedora EFI-boot options.

If you want to try for an EFI-mode boot of Linux, you can do so: Install the EFI filesystem driver for whatever filesystem you're using on /boot (or / if you don't have a separate /boot partition) and in Linux (even in a BIOS-mode boot) run the mkrlconf.sh script that comes with rEFInd. This should enable the direct Fedora boot option(s) in the rEFInd menu to work; however, given the symptoms you reported, it's possible that they'll fail with a blank screen. This symptom is a common one today. It's related to problems with Linux video drivers in EFI mode. There are numerous fixes, but most of them are hardware-specific, and I haven't been keeping track of them all, so I'm not sure exactly what you'd need. The one that's most hardware-agnostic is to add nomodeset to the kernel options, which you can do by editing the /boot/refind_linux.conf file (which is created by the mkrlconf.sh script).


The UEFI bootmanager in MSI GE40 first searches EFI/Microsoft/Boot/bootmgfw.efi. If this file exist, Windows 8 starts even if EFI/Boot/bootx64.efi is changed by Linux installer. One of the method for avoid this, when grub is used, is to rename EFI/Microsoft/Boot/bootmgfw.efi to another name, and edit /etc/grub.d/40_custom (or similar configuration file ) so that the renamed file is loaded.

The blank screen problem can be solved by using the latest kernel. In fact I could install manjaro linux 0.8.8rc2 (kernel 3.10.17) to this model using a USB pendrive. However, manjaro linux (kernel 3.10.15) can not be installed with the same method.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.