0

Today I opened my PC after some days and I noticed that it started doing something like a recovery on my storage space pool, before booting.

Once booted, I've tried to open the pool to see if the files where all ok and an "Access denied" error appeared.

I've tried changing the pool's letter, re-taking the ownership of the drive and, after some troubles, it worked fine.

Now seems like I've got a more serious problem: I miss something like 500GB of data!

The pool's info report that the data is still on, while the disk properties says that they're not here anymore.

Here's a screenshot to make thing clearer:

Missing data

As you can see, on the left there's the pool capacity and it says that I'm using 1.16 TG out of 1.58 while in explorer it says that I've got 1.66TB FREE ou of 1.95TB and this is quite insane!

Plus, a lot of files and folders are corrupted!

What the hell is going on?

  • 1
    Its likely Hardware has failed. You do have a backup right? – Ramhound Sep 27 '13 at 11:09
  • This storage space was configured to do a mirroring, so this was supposed t be my backup. Do you think that I can unplug one of the disks and see if the other has still the data that I need? – StepTNT Sep 27 '13 at 11:59
  • Mirroring is not backup (recover your data if it is lost or damaged). Mirroring is fault tolerance (continue operating if hardware fails). – David Schwartz Sep 27 '13 at 12:13
  • @StepTNT - You are suppose to have 3 copies of data. The original copy, and backup, and a backup offsite. Your backup policy should only allow for data loss in a given timeframe that you decide is acceptable. Storage Spaces is a great idea for data storage but not as a means for a backup. You should backup Storage Spaces storage. – Ramhound Sep 27 '13 at 12:21
2

Total and free space of drives are read from a value in the drives properties, not calculated reading all file sizes each time you access it. Maybe if the drives has errors, the information about total and free space is corrupted, and the files you see are all that are there.

  1. Maybe there are still some errors, you could run checkdisk from a command prompt to further repair it. For that, press Start button, type "cmd" on search field, right click on "cmd.exe" and choose "Run as an admin". Then, in the black window that appears, type:

    chkdsk j: /f
    
  2. It is also possible that you have hidden files or directories. To access them, follow this instructions: Hidden files in Windows Explorer

  3. Maybe you have a virus. Check both viruses and malware, maybe with free AVG and MalwareBytes' Antimalware.

  4. Also maybe you have not retake complete ownership of all files and folders privileges. You can boot in safe mode as explainend here: How to boot in safe mode, and them, try to take ownership again. This ensures you take all files and folders.

  5. If you want a visual tool to help you check which files are there, and what use has the drive space, I recommend you free WinDirStat.

  • He will likely have some problems solving this problem as Storage Space is a Windows 8 only concept. So your traditional tools to fix hdd problems might not work. – Ramhound Sep 27 '13 at 11:34
  • Thanks, chkdsk just saved me from having to recover nearly 1TB from the cloud. – majinnaibu Nov 8 '16 at 6:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.