2

I have previously had CUDA running successfully on 2 PCs, but after extensive use (a couple of hours of computations) it becomes disabled. All CUDA applications (eg TechpowerUp GPU-Z) say that Cuda is not installed (cuda tickbox is empty on this app, similar result on others). The same happens on both PCs.

If I reboot the PC, the problem will often (not always) rectify itself.

I've tried re-intsalling CUDA drivers (5.5 and 5.0), but the same thing always happens.

It seems very strange that I see this happening consistently on both PCs, yet can't find any references on the internet to other people experiencing the same.

Any help/ideas would be appreciated.

UDPATE: it has been suggested I run nvidia-smi. Results are:

C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi
Wed Oct 02 14:16:35 2013
+------------------------------------------------------+
| NVIDIA-SMI 5.320.57 Driver Version: 320.57 |
|-------------------------------+----------------------+----------------------+
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTS 240 WDDM | 0000:01:00.0 N/A | N/A |
| 56% 70C N/A N/A / N/A | 997MB / 998MB | N/A Default |
+-------------------------------+----------------------+----------------------+
+-----------------------------------------------------------------------------+
| Compute processes: GPU Memory |
| GPU PID Process name Usage |
|=============================================================================|
| 0 Not Supported |
+-----------------------------------------------------------------------------+

1

I've found the cause here, it was quite unexpected.

I use Remote Desktop to communicate between my PCs. Apparently this takes over the graphics driver on the host machine and disables CUDA. I will try using something like VNC instead.

  • In view of the answer, your post was was really misleading. – harrymc Oct 4 '13 at 13:06
  • Remote Desktop wasn't even mentioned, while it changes everything. – harrymc Oct 5 '13 at 7:17
  • 1
    that's the point, I had absolutely no idea it would make any difference. If I had, I wouldn't have needed to ask the question. I also didn't mention everything else I do on this PC, like surf the web, email etc because I didn't think they were relevant either. – mcmillab Oct 6 '13 at 23:32
  • it seems I'm no longer having this problem since upgrading to Windows 10 - is this expected? – mcmillab Dec 27 '15 at 8:36
  • Are you sure? I use RDP too and I'm having the same problem too on Windows 10 x64. I have 2x 980Ti, but gpu1 (the second gpu) have its CUDA deactivated and couldn't be accessed in Theano. So I only have gpu0 (the main GPU, which also connects to the monitor) available. But the gpu1 load is 0% in CPU-Z, so I'm not sure if it's locked by RDP. – rilut Jul 25 '16 at 8:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.