So I have tried for a long time to get my problem fixed but without result. I can't run most applets in a browser - need it to log into my bank account.

I have removed all java versions by using the programs and features to uninstall, and then deleting the remaining java folders in both C:\program_files folders. I then on a suggestion from a friend removed all association of java in my classpath variable. At this point it is to my knowledge that there are no more java on my computer (even cmd prompt doesn't recognize java commands). So with no java I tried to install the newst update 40, both x86 and x64 versions.

I am still however unable to use any applet in my browser. And for your information I use Opera as my standard broswer but have also tried with Explorer and neither of them does anything.

The error I get it a little red 'X' and the java console message ClassNotFoundException.

Any suggestions to what I am doing wrong?

- Additional information that might be helpful.

This is from the java console when I get the error:

Java Plug-in
Using JRE version 1.7.0_40-b43 Java HotSpot(TM) Client VM
User home directory = C:\Users\swidtter

This is what I get from using the java -version command in the prompt:

java version "1.7.0_40"
Java(TM) SE Runtime Environment (build 1.7.0_40-b43)
Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)

And when I check the Java Control panel to view the runtime settings I only see my x86 java in the path, and if I add the x64 location and then close down the control panel it reverts back to not having it listed (and yes I did remember to apply and save). My classpath links to both


and my Path doesn't have any java relation in it(which I think it shouldn't)

C:\program_files(x86)\NVIDIA Corporation\PhysX\Common;C:\program_files(x86)\AMD APP\bin\x86_64;C:\program_files(x86)\AMD APP\bin\x86;C:\Users\swidtter\apache-ant-1.9.0\bin;C:\program_files(x86)\Common Files\Microsoft Shared\Windows Live;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\program_files(x86)\ATI Technologies\ATI.ACE\Core-Static;C:\program_files\TortoiseHg\;C:\program_files(x86)\Git\cmd;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\program_files(x86)\QuickTime\QTSystem\;C:\program_files\Microsoft\Web Platform Installer\;C:\program_files(x86)\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\;C:\program_files(x86)\Windows Kits\8.0\Windows Performance Toolkit\;C:\program_files\Microsoft SQL Server\110\Tools\Binn\;C:\program_files\doxygen\bin;C:\program_files(x86)\MiKTeX 2.9\miktex\bin\

- Thanks And please I will provide all the information you need if you have a suggestion.

  • Does it work for other people who use the same bank? Have you been able to try it on another (trusted) computer?
    – Mokubai
    Sep 28, 2013 at 21:29
  • Yes, I can't even run the java verify applet from Oracle.
    – Swidtter
    Sep 28, 2013 at 21:33
  • Does opera:plugins show the correct Java version as enabled?
    – nixda
    Sep 28, 2013 at 21:46
  • I think so. But even then I have tried with Explorer too. Java(TM) (2) Version: Next Generation Java Plug-in 10.40.2 for Mozilla browsers
    – Swidtter
    Sep 28, 2013 at 21:55

1 Answer 1


Perhaps it is worth trying or verifying the following:

  • Adding the website URL to the site list on the Java control panel
  • Do you have the default internet explorer settings for the internet security zone?
  • Try installing both the 32-bit and 64-bit java versions (available through offline installers)

Hope this helps you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.