15

I've got a problem with vlc playing some file formats, for example mkv or m2ts (I didn't notice this problem with avi though). The sound plays ok, than dissappears for a second or two, than re-appears. It occurs around once every 10 seconds. This is really annoying and prevents me from using VLC for those files, which, by the way, play completely ok in Media Player.

Here's what I already tried to do about it:

  1. Change VLC sound output method
  2. Re-install k-lite codec pack
  3. Re-install/upgrade VLC

My configuration is:

  1. Soundcard: Asus Xonar Essence
  2. Operating system: Windows 7
  3. Codecs: K-Lite

What else could I try to fix this issue?

7
  • What do you mean with "Change VLC sound output method"? Have you changed the output modules?
    – Christian
    Sep 29 '13 at 16:37
  • @Chris yes. I've tried several, and the problem persists in all of them Sep 29 '13 at 16:40
  • 1
    How are you playing the files? locally? from a media server? m2ts are bluray so the files can be HUGE, maybe your computer/network can not handle the thru-put. The same with the mkv files, which can be small or bluray quality (>20GB). Every 10 secs.... sounds like its trying to catch up and can not.
    – Logman
    Sep 29 '13 at 16:43
  • I'm playing the files from a local wd caviar black hard drive, although it is being used at the moment of playback by other software. However, the issue is reproduceable with VLC with me, and doesn't occur with Media Player Sep 29 '13 at 16:50
  • open up Resource Monitor (RUN > Resmon.exe) and watch the hdd/cpu/mem... pretty sure your hd can not keep up...esp if the hd is getting hit by other applications at the same time
    – Logman
    Sep 29 '13 at 16:57
13

in VLC... Tools – Preferences - Select Input & Codecs option ... Look for "Skip the loop filter for H.264 decoding " or “Skip H.264 in-loop deblocking filter” and select ALL from the drop down list.

Save the preference and play the video.

6
  • 3
    doesn't work, the problem persists. Also tried GPU acceleration on and off ( Sep 29 '13 at 17:09
  • 3
    on the other hand, I got the gaps to be shorter by changing default caching policy to "lowest latency". Got them to be really long when I changed to "highest latency" Sep 29 '13 at 17:16
  • This worked to clear my "sound stops minutes into video, resumes later" problem that I started seeing after upgrading to 14.04 LTS. Aug 26 '14 at 19:53
  • 2
    Tools-Prefs-Audio-Modules-WaveOut worked for me.
    – karmington
    Dec 22 '14 at 16:28
  • 1
    No change here in 2018.
    – 2540625
    Apr 13 '18 at 5:34
2

Open VLC Tools->Preferences->Audio->Output->Output Module

Select a different output module, then Save

Repeat until the problem goes away.

1
  • Did not work for my H264 mp4 file. It works fine in WMP and GOM.
    – Heroman
    Oct 8 at 14:10
2

I've continued to have problems with VLC audio cutting out. Recently I discovered the problem goes away if I close all, or nearly all, my Chrome web browser tabs. This is puzzling; resource utilization doesn't seem to be the issue, as going from 30 to 5 open Chrome tabs had little effect on resources other than memory, and no effect on VLC's behavior, while going from 5 to 3 tabs eliminates the problem entirely--regardless of which 3 tabs I leave open.

I can still watch VLC videos if I use Firefox instead.

I'm using Windows 7 64-bit and Chrome Version 58.0.3029.110 (64-bit).

2
  • you rare RIGHT! Nothing I did would stop VLC from shuttering at exactly every 30 seconds of the videos. Closing chrome solved it. (I only had 3 tabs open! On a 8GB RAM machine....)
    – yurividal
    Jun 25 '19 at 7:21
  • @yurividal, IIRC there is a Windows timer that both Chrome and VLC fiddle with, which controls how often some particular interrupt is generated. I suspect it has to do with that. I've also noticed that sometimes my Windows 10 computer won't stay asleep for more than a few seconds if VLC is showing a video. eMule causes the same issue, and I suspect it is also due to using an interrupt to switch between the different files & hosts eMule is uploading or downloading to or from.
    – Phil Goetz
    Oct 13 at 1:49
0

If the answer is to listen to the video, rather that resolve the VLC problem, I have a couple of workarounds; essentially, open it in something else. I have some .ts files recorded with a (perfectly good) Hauppage USB stick tuner using NextPVR, with a poor antenna connection. The picture breaks up occasionally (whatever the viewer). but in VLC 3.0.8 the sound cuts out intermittently. I think it's been said that the sound is OK in Firefox (on a PC?); I confirm this, but add that it's fine when opening the file in Kodi on an Android phone (I make a network connection, without copying the file, and open it by clicking on it in Total Commander for Android with LAN plugin, and selecting Kodi). No need for Kodi unapproved addons.

From this and other comments, this looks like something for the VLC developers to look into.

Not the answer you're looking for? Browse other questions tagged or ask your own question.