2

I have installed nxserver on a ubuntu machine and am able to connect to this machine via the free NX client on a windows machine. Things seem to be working fine except that the xterm has a weird NX prompt rather than a regular shell prompt. Below is what I got in the xterm window:

HELLO NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: 3.5.0) NX> 105 bash bash NX> 105

This prompt only echoes whatever I type and does absolutely nothing else. Anyone has an idea how to initiate a shell prompt?

0

I ran into this problem as well. I uncommented the

 ENABLE_USERMODE_AUTHENTICATION and ENABLE_PASSDB_AUTHENTICATION

in my node.conf file, and that solved the problem for me at least.

What you will find is that this prompt is being generated by the nxserver executable, which is actually a shell script and not a binary. You can look in the shell script for the valid commands such as "login" and "list". Since it appears to be something the NX client communicates with, the help appears to never have been put in place to give you some idea of what is going on, so the source code is the only help there is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.