1

I hope you can help me. I have tried to log on but I get the following error code

"The User Profile Service failed the logon. User profile cannot be loaded”

The problem I have is that I only have 1 profile which appears to be the one that is corrupted. So I cannot open it in safe mode...anyone got any suggestions?

Thanks

  • 1
    You don't have at least one more login to use for that machine? Alternatively, this is a domain connected machine, with no user data on it, so you can just image it, right? – Dan Sep 26 '13 at 20:09
1

The following assumes that the machine is an AD domain member:

Connect to the machine remotely with Registry Editor. Open regedit on a remote computer, using alternate credentials if necessary. Such as Domain Admin credentials. In Regedit, click File -> Connect Network Registry... and connect to the computer with the busted profile.

Since you say that there is only 1 profile on this machine, then it has to be Administrator (SID-500.)

So now that you are connected to the remote machine's registry, navigate to

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList

And delete every subkey that looks like S-1-5-21-xxxxxx-500.

Next, open up a Command Prompt, Cmd.exe, again using alternate credentials such as a Domain Admin, that has privileges on the remote machine. Run the following command:

C:\> rd /s \\computer01\C$\Users\Administrator

Delete the directory. Also delete any other similar directory like

\\computer01\C$\Users\Administrator.Domain if it exists. If this is Windows XP or 2003, the profiles will be under Documents and Settings, instead of Users.

Problem solved.


Now, if this is not a domain-joined computer, then your only options are to do something like

  • Hit F12 during boot and use the recovery options, such as Last Known Good Configuration, or Repair, etc.
  • Use the Windows installation media (DVD, USB,) if you don't have a recovery partition, and use that to repair, restore from backup, etc. At the very least you can open a command prompt and copy off some files if you need to reimage the thing.

Good luck.

| improve this answer | |
  • Any idea why this happens? I've had someone hand me their laptop to fix with this same error that I fixed a month ago. Why does it keep happening? Is there a way to fix it once and for all? – crmpicco Oct 3 '15 at 17:07
0

You could also try connecting to the server using the Computer Management MMC (compmgmt.msc) and attempt to create a new local user account.

| improve this answer | |
0

This fix is great in a workgroup environment, however we encountered this issue on a domain level, and applying the fix for each computer was time consuming. Eventually we figured out that a permission change in the "Default User" profile enabled users to log on (make sure to enable "show hidden files")

We solved it by adjusting our GPO with the additional setting of “authenticated Users” in the default user profile.

The path for this setting in your GPO is: Computer configuration/policies/windows settings/security settings/file system/

In %SystemDrive%\Users\Default add NT Authority\Authenticated Users with Full Control permission

After it was pushed down, all users that previously had this issue were able top log on

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy