23

After 30 minutes my Windows 7 PC goes to Standby. Problem is, when I get it back to normal, Wi-Fi is disconnected. And it doesn't just reconnect and come back in 10 seconds. For example, when I start it up, I have to click on the Wi-Fi symbol, select the Wi-Fi and connect to it. This takes much longer and made me think about disabling standby altogether - not the best solution.

Some information:

  • The PC is a standard desktop machine, no laptop.
  • There is no additional power management software installed.
  • The Wireless Network Adapter (Atheros AR5005G) is set to not being able to be deactivated to save energy in Device Manager.
  • The Wireless Network Adapter uses no special software from Atheros, only the driver that was installed by Windows itself
  • Control panel > Power options > Change plan settings > Change advanced power settings > Wireless adapter settings > Power saving mode = Maximum Performance

Any idea what could cause this behaviour? How can I stop it from losing Wi-Fi or reconnect normally?

  • Sounds like your power mangement software is turning the device off. – Ramhound Sep 30 '13 at 12:51
  • There is no power management software installed (that I know of. Couldn't find any looking through Programs). This is a desktop PC, so also no special BIOS stuff going on, I think. – janpio Sep 30 '13 at 12:56
  • 2
    Clarify your question with that informat. Windows comes with power management tools so I would double check device properties. Update your question with all information learned by doing this. – Ramhound Sep 30 '13 at 12:58
  • Any way to export this configuration stuff in a sane way? Additionally I'm on German Win7, the translation of the normal options are horrible so I'm having problems connecting the English names to the German ones... (e.g. "Deaktivieren" = "Standby" sometimes) – janpio Sep 30 '13 at 13:00
  • 2
    I suggested you just confirm what the device does when the computer goes to sleep which can be found on the properties of the device itself in Device Manager. I suggested you clarify your computer isn't a laptop in the question itself. – Ramhound Sep 30 '13 at 13:12
16

I cannot believe this, but after months of trying to fix this, it turns out that, for me, checking ON (enabled) the "Allow the computer to turn off this device to save power” worked.

Got this idea from Intel’s My WiFi Technology stops working after resuming from sleep or hibernate in Windows 7. My guess is that the driver expects to turn the network card back on after sleep or on a cold boot, and because the option is turned off, it toggles the "switch" from being already on to off. Maybe?

Anyway it works for me now, perfectly.

| improve this answer | |
  • 2
    Seems completely backwards, but worked for me too. – Paul Apr 13 '14 at 1:17
  • 1
    Actually turning it 'off' worked for me on windows 10 Samsung laptop, but +1 anyway. – Piotr Falkowski Dec 27 '15 at 20:03
  • This worked for me as well! My Intel Wireless card started disconnecting and failing to reconnect after sleep. One of the first things I tried was to uncheck the "Allow the computer to turn off this device to save power" option. This didn't work. So the next thing I did was update the driver. This also didn't work. But the combination of updating the driver and enabling the "Allow the computer to turn off this device to save power" option seems to have fixed it for me! – Brian Rothstein Jan 18 '17 at 21:52
  • Wifi network disappears after sleep mode Actually turning it 'off' worked for me on windows 8.1 Lenovo laptop, but +1 anyway. My WiFi Technology stops working after resuming from sleep or hibernate in Windows. hide wireless network suddenly after sleep or hibernate – saber tabatabaee yazdi Jun 26 '18 at 20:40
11

Apparently, disabling a Windows power saving option causes a family of Intel drivers to malfunction. I was able to solve this issue on two Intel network card-equipped Lenovo ThinkPads. So if your computer also relies on an Intel WiFi network card, I'd suggest you :

  1. Go to the Windows Control Panel
  2. Click on System
  3. Select the Device Manager
  4. Right-click on your Intel wireless device and choose Properties
  5. In the tab Power Management, enable the option Allow the computer to turn off the device to save power.

This solved my problem. As I am not using an English version of Windows, let me know if you can't find those menus.

| improve this answer | |
  • +1 for the step by step guide, worked for me in Windows 10. Thank you, this behaviour was a major PITA – smcs May 2 at 12:16
  • I was wrong, it only worked once. Sigh – smcs May 6 at 20:12
5

For me on an HP EliteBook Folio 9480m (Windows 7 x64 SP1 with an Intel Wifi chip), the solution was to switch "Allow the computer to turn off this device to save power" OFF, and then back ON. Unbelievable!

| improve this answer | |
  • This was good advice. "Allow ... to save power" was already on for me, so other people's advice didn't apply and I was going to move on until I read this answer. Similar model, running Windows 10. – nomen Jun 7 at 15:38
2

After much aggravation, and trying all the power management options, I discovered that windows was using more than one utility to manage the wireless adapter. After exiting the trendnet utility and disabling it from starting up in the system configuration utility, I restarted the computer to find the problem solved.

The clue that led me to this was having more than one wireless icon in the system tray. The one in green happened to be trendnet.

| improve this answer | |
  • Lenovo Thinkpad T540p user running Win7 x64 here - had a problem very similar to the one described in this answer. I ended up delving into Power Options (advanced settings) and setting the "Wireless Network Card" (or whatever it was called) to maximum performance on both battery & plugged in (and, like many others in this thread, re-enabled the "allow the computer to turn off this device to save power" checkbox that you get to via Device Manager > Network Cards > yadda-yadda-yadda). – Pockets May 11 '16 at 5:21
0

For those, like myself, whose issue persisted after trying the apparently popular solution enabling/disabling the Power Management option, consider this:

Do you happen to have LogMeIn Hamachi on your PC? The quickest fix I came upon so far was to disable it "Network Connections" once you get the internet issue. Internet connectivity automatically fixes itself, and Hamachi network will will re-enable itself automatically as well.

This works for me; otherwise I used to disable & re-enable my Wireless Network... which fixes the issue only temporarily.

There's likely a more permanent fix to avoid this problem altogether, but I don't have the smarts or time to figure it out.

| improve this answer | |
0

The accepted answer (enabling - or disabling - "Allow the computer to turn off this device to save power") did not work for me on my new ASUSPRO D641MD when it would wake up from sleep mode.

In my case, I had to Uninstall device for the wifi adapter in the Device manager. When I rebooted, it was re-installed and has been working properly since.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.