I don't even know how to begin trouble shooting this issue. My wireless network is set up with 3 different SSIDs and 3 different VLANs, one for each of the different SSIDs. Devices on the WIFI can see other devices so long as they are on different VLANs or different networks. If they are on the same VLAN they can't see each other.

If I run TCPDump on the gateway I can see the ARP requests. If I run tcpdump on the machine I'm trying to connect to I never see any ARP requests.

Our WIFI hubs are EnGenius APs and we have D-Link switches

  • 1
    Routes between the three, network topology description?
    – CodeMonkey
    Sep 30 '13 at 17:21
  • The gateway/firewall is configured with a separate port for the 3 VLANs, the wired LAN and the internet. The LAN has it's own switch with any wired computer. The switch for the VLANs has 3 ports that are exclusive to each of the VLANs. These ports are then connection to the gateway/firewall. All other ports on the switch are tagged for all 3 VLANs. The various wireless APs are connected to these ports on the switch.
    – MeOMy
    Sep 30 '13 at 17:45
  • is AP Isolation enabled on your APs? It might cause your L2 partners to fail to connect, while allowing your L3 partners to communicate via the VLAN routing. Sep 30 '13 at 18:22

Could be (from described symptoms) you have "wireless isolation" ([or, possibly, "station separation" going and looking at one of my Engenius APs - but different EnGenius models vary a bit] set on the EnGenius APs.

That is designed for use where you DON'T want devices on the wireless to talk to each other (ie, you are offering internet connectivity, but want to discourage use of your wireless for inter-computer traffic - typically in a public-service environment.)

Frankly a bit odd to bother having 3VLANs if they all become merged in the end. In a similar setup I offer multiple SSIDs, mostly to split the "number of hosts per SSID" down a bit, though I'm not sure how much it really helps when they are [in my case] all from the same AP.

  • That is what it was. It's "Station separation" on my APs. Thanks
    – MeOMy
    Sep 30 '13 at 19:04
  • You are welcome. If the answer is correct and solved your problem you might "accept" the answer - it's one of the ways this place works.
    – Ecnerwal
    Oct 3 '13 at 1:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.