I made a usb boot stick using Unetbootin, on mac osx (the latest one).

I created the stick (after formatting it), and then plug it into my EEE PC X101CH

the bios boot menu shows 2 options for the usb which I don't understand. One is

  1. Corsair Flash Voyager 0.00
  2. UEFI: Corsair Flash Voyager 0.00

I don't understand why 2 shows. and why uefi is showing, when I believe the eee pc runs bios. If I click on 1 it says "missing operating system" , and then just loads windows.

If I click on 2 nothing happens, and windows just loads.

This happens with a few other distros too. Like Lubuntu.

I don't know if the issue is with Unetbootin on a MAC or my EEE PC

I tried to run Puppy Linux on it, which works, though it has a problem loading X at the beginning. Eventually I got through. I can run a pre made (many months ago) Linux mint usb stick on it. However, the graphical GUI doesn't load, I just get a linux mint dos.

Any suggestions?

  • Looks like the OS X version of Unetbootin may not write the MBR correctly . . . and I believe the Cedar Trail CPUs do support UEFI, though not sure what particular mobo that that EEE PC has . . . – ernie Oct 2 '13 at 0:04

I would discard problems with Unetbootin just not using it and instead using Ubuntu's guide:

  1. Download the iso image
  2. Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight).
  3. Convert the .iso file to .img using the convert option of hdiutil (e.g., hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/linux-image.iso) Note: OS X tends to put the .dmg ending on the output file automatically.
  4. Run diskutil list to get the current list of devices.
  5. Insert your flash media.
  6. Run diskutil list again and determine the device node assigned to your flash media (e.g. /dev/disk2).
  7. Run diskutil unmountDisk /dev/diskN (replace N with the disk number from the last command; in the previous example, N would be 2).
  8. Execute sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).


    • Using /dev/rdisk instead of /dev/disk may be faster
    • If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M
    • If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the Disk Utility.app and unmount (don't eject) the drive
  9. Run diskutil eject /dev/diskN and remove your flash media when the command completes.
  10. Restart your Mac and press alt/option key while the Mac is restarting to choose the USB stick.

Source: http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-mac-osx

  • thankyou. in what you told me to type, it includes this '~/path/' do i literally type this? or the folder the file is located in – hiro Oct 2 '13 at 1:11
  • could i ask what exactly we are doing here ? what does bs=1m mean ? in the link you gave me there's also this step: 4. Now, download the latest syslinux.zip, and extract and locate the mbr.bin Go back to the extracted folder in the terminal, and install mbr.bin sudo dd conv=notrunc bs=440 count=1 if=mbr.bin of=/dev/rdisk2 how would i install the mbr ? 3. is it feasible to expect a future mac version of unetbootin to be fixed with this issue ? – hiro Oct 3 '13 at 14:54
  • You are copying the exact content of the iso into the usb stick. bs means read and write up to BYTES bytes at a time, so it reads/writes 1 megabyte at time. Not true; I copied the exact content of the help, you are looking at another link. Step 4 is the same in both places. I don't have the slightness idea. I'm not a developer of unetbootin – Braiam Oct 3 '13 at 15:01
  • it worked. thankyou very much !!! may i ask, do you think this method will work with other distributions, such as Linux Mint and Manjaro ? – hiro Oct 3 '13 at 17:07
  • 1
    ps, i would just like to add to anyone reading this, sometimes you may need to add .dmg (if you used a mac) in step 8 Execute sudo dd if=/path/to/downloaded.img.dmg so in my case it was 'sudo dd if=/Users/h/Downloads/Lubuntu.img.dmg' – hiro Oct 3 '13 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.