3

I have a PC at home running windows 7. Name WIN7, ip 192.168.1.200, member of WORKGROUP. The only user is me.

My work laptop is also running Windows 7. Name LASTNAME-OFFICE, ip 192.168.1.101, member of domain WORK.CORP. The only user is firstname.lastname.

WIN7 has a number of shared folders. BIG, LIB3, TMP, and USERS. These shares work from linux and from a laptop which is also in WORKGROUP. I have not enabled the guest account on WIN7. I have said passwords are not required in advanced sharing on WIN7.

The LASTNAME-OFFICE laptop cannot access the shared folders on the WIN7 box. I have tried using the ip like:

\\192.168.1.200\BIG

But it does not work. The shares are definitely working, because if I run a virtual linux (ubuntu) on the laptop, it can access the shares. So I figure this must be a problem with the config on the work laptop. Or is it purely because the domain and workgroup do not match?

How can I fix or work around this? I do not have permission to create a local account on the laptop.

Thanks

EDIT: Sorry, I did not explain the situation properly. It does not appear to connect at all, I never get ot the point of being asked for credentials.

Windows Explorer waits a while before it gives the message:

Windows cannot access \\192.168.1.200\BIG
Check the spelling of the name. Otherwise there might be a problem with your network.
Error code: 0x80004005
Unspecified error

And when I click on diagnose it says

Windows Network Diagnostics Publisher details 
Issues found 
The remote device or resource won't accept the connection
The device or resource (192.168.1.200) is not set up to accept connections on port "The File and printer sharing (SMB)".
Contact your network administrator

From the command prompt

C:\>net use W: \\192.168.1.200\ /USER:WIN7\me
System error 53 has occurred.

The network path was not found.

But as I said, it works fine from other computers, and from VirtualBox VM's running on the laptop. I do have both Cisco Annyconnect Client and VirtualBox installed. But neither of them are running.

  • 1
    See if when prompted for the username and password of your WIN7 computer, use WORKGROUP\me as the username. This will force the WORKGROUP domain instead of WORK.CORP. – kobaltz Oct 2 '13 at 14:39
  • Sorry, I did not explain the error properly. It is not connecting, so I am not being prompted for credentials. I have added this info to the question. – Sodved Oct 2 '13 at 17:15
3

You need to specify the username to use. If you map the network drive in Explorer, there is a tick box for "Connect using different credentials". If using the NET USE command, add "/user:computer\user *". The asterisk prompt for the password.

Other things to try including checking for the firewall (ports 138 and 139 need to be opened). Is your laptop set to the 'Home' or 'Work' network location? You can open the Network and Sharing Center, click on the network connection in the center (it may say Public), and choose the new location there.

Edit based on OP's edits - You may need to enable and set Remote Access to be visible and turned on. If you are an administrator, you can try running a script such as posted below as an Administrator on the "server" PC - the laptop:

@echo off

netcfg.exe -c s -i MS_Server
netcfg.exe -c s -i MS_Pacer
netcfg.exe -c p -i MS_LLTDIO
netcfg.exe -c p -i MS_RSPNDR

netsh advfirewall firewall set rule group="windows management instrumentation (wmi)" new enable=yes
netsh advfirewall firewall set rule group="File and Printer Sharing" new enable=yes
netsh firewall set service remoteadmin enable
netsh advfirewall firewall set rule group="remote administration" new enable=yes

netsh advfirewall firewall add rule name="135TCP-In" dir=in action=allow protocol=TCP localport=135
netsh advfirewall firewall add rule name="135TCP-Out" dir=out action=allow protocol=TCP localport=135
netsh advfirewall firewall add rule name="135UDP-In" dir=in action=allow protocol=UDP localport=135
netsh advfirewall firewall add rule name="135UDP-Out" dir=out action=allow protocol=UDP localport=135

reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f
| improve this answer | |
  • Does not seem to be connecting. I tried from the command prompt but got System error 53 has occurred. The network path was not found. I have added more details to the question. – Sodved Oct 2 '13 at 17:17
  • @Sodved Edited to update based on your edit – Canadian Luke Oct 2 '13 at 17:27
  • My network connection is of the type Domain and it is not hyperlinked in the Network and Sharing panel so I am not able to change it to a different type. – bgmCoder Jun 14 '17 at 16:53
  • I have the same problem - I can connect to the admin share from a computer in WORKGROUP but can't connect from one connected to a DOMAIN. I opened the two ports but still can't connect - it says the location can't be found. – bgmCoder Jun 14 '17 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.